Toad World® Forums

3.5 beta Defect - DB2 LUW MQTs error in Viewer


#1

How do I report a defect? Where can I attach a screen shot?

This defect is for version 3.5 Beta Version (3.5.0.2831). DB2 LUW MQTs do not work at all in the Viewer (View Details) and an error is always produced. This issue did not exist in the 3.4 version. This is the error that shows in the Viewer: Item has already been added. Key in dictionary: ‘3’ Key being added: ‘3’

This error example was produced with a DB2 9.7 LUW database, but I think all LUW versions have it.


#2

I have installed the latest beta version 3.5.0.2904 and do not see this issue.

Please try that latest beta build.

Some questions that might assist in problem determination:

How many database connections do you have concurrently connected?

If multiple connections, what are they (all DB2 LUW, other RDBMS, etc.)?

In the Object Explorer, do you have a specific Schema selected or have a * specified for the Schema (for all schemas)? If a specific schema is selected, do you have the issue with any other schema?

Do you have multiple MQ Tables with the same names (but different schemas)? - this should be fine in Toad - but just wondering

Can you successfully right-click on an MQ Table and select Operations - Create Like and successfully clone an MQ Table?


#3

Jeff,

Are you telling me that you can use 3.5.0.2904, connect to a DB2 9.7 LUW (we use AIX) database and see any MQT in the View? This does not work on any machine
or any DB2 LUW connection we tried. Here is a screenshot. The same issue happens without a filter and with any schema or LUW database. The Create Like for the Clone works.

Panos Menelaou

AVP, Enterprise Information Services

SunTrust Bank

Direct: 404-813-4978

From: Jeff Podlasek [mailto:bounce-Jeff_Podlasek@toadworld.com]

Sent: Wednesday, April 09, 2014 4:25 PM

To: toaddatapointbeta@toadworld.com

Subject: RE: [Toad Data Point - Beta Discussion Forum] 3.5 beta Defect - DB2 LUW MQTs error in Viewer

RE: 3.5 beta Defect - DB2 LUW MQTs error in Viewer

Reply by Jeff Podlasek

I have installed the latest beta version 3.5.0.2904 and do not see this issue.

Please try that latest beta build.

Some questions that might assist in problem determination:

How many database connections do you have concurrently connected?

If multiple connections, what are they (all DB2 LUW, other RDBMS, etc.)?

In the Object Explorer, do you have a specific Schema selected or have a * specified for the Schema (for all schemas)? If a specific schema is selected, do you have the issue with any other
schema?

Do you have multiple MQ Tables with the same names (but different schemas)? - this should be fine in Toad - but just wondering

Can you successfully right-click on an MQ Table and select Operations - Create Like and successfully clone an MQ Table?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad Data Point - Beta
notifications altogether.

Toad Data Point - Beta Discussion Forum

Flag
this post as spam/abuse.

LEGAL DISCLAIMER

The information transmitted is intended solely for the individual or entity to which it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of or taking action in reliance upon this information
by persons or entities other than the intended recipient is prohibited. If you have received this email in error please contact the sender and delete the material from any computer.

By replying to this e-mail, you consent to SunTrust’s monitoring activities of all communication that occurs on SunTrust’s systems.

SunTrust is a federally registered service mark of SunTrust Banks, Inc.

[ST:XCL]


#4

By the way, we do not have this issue with 3.4 for the exact same databases, schemas, MQTs, etc.

Panos Menelaou

AVP, Enterprise Information Services

SunTrust Bank

Direct: 404-813-4978

From: Menelaou.Panos

Sent: Wednesday, April 09, 2014 4:41 PM

To: toaddatapointbeta@toadworld.com

Subject: RE: [Toad Data Point - Beta Discussion Forum] 3.5 beta Defect - DB2 LUW MQTs error in Viewer

Jeff,

Are you telling me that you can use 3.5.0.2904, connect to a DB2 9.7 LUW (we use AIX) database and see any MQT in the View? This does not work on any machine
or any DB2 LUW connection we tried. Here is a screenshot. The same issue happens without a filter and with any schema or LUW database. The Create Like for the Clone works.

Panos Menelaou

AVP, Enterprise Information Services

SunTrust Bank

Direct: 404-813-4978

From: Jeff Podlasek [mailto:bounce-Jeff_Podlasek@toadworld.com]

Sent: Wednesday, April 09, 2014 4:25 PM

To: toaddatapointbeta@toadworld.com

Subject: RE: [Toad Data Point - Beta Discussion Forum] 3.5 beta Defect - DB2 LUW MQTs error in Viewer

RE: 3.5 beta Defect - DB2 LUW MQTs error in Viewer

Reply by Jeff Podlasek

I have installed the latest beta version 3.5.0.2904 and do not see this issue.

Please try that latest beta build.

Some questions that might assist in problem determination:

How many database connections do you have concurrently connected?

If multiple connections, what are they (all DB2 LUW, other RDBMS, etc.)?

In the Object Explorer, do you have a specific Schema selected or have a * specified for the Schema (for all schemas)? If a specific schema is selected, do you have the issue with any other
schema?

Do you have multiple MQ Tables with the same names (but different schemas)? - this should be fine in Toad - but just wondering

Can you successfully right-click on an MQ Table and select Operations - Create Like and successfully clone an MQ Table?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad Data Point - Beta
notifications altogether.

Toad Data Point - Beta Discussion Forum

Flag
this post as spam/abuse.

LEGAL DISCLAIMER

The information transmitted is intended solely for the individual or entity to which it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of or taking action in reliance upon this information
by persons or entities other than the intended recipient is prohibited. If you have received this email in error please contact the sender and delete the material from any computer.

By replying to this e-mail, you consent to SunTrust’s monitoring activities of all communication that occurs on SunTrust’s systems.

SunTrust is a federally registered service mark of SunTrust Banks, Inc.

[ST:XCL]


#5

Panos,

Your screenshot did not post - please try posting that again.

Yes - I am successfully displaying MQ Tables using the latest beta against a v9.7 LUW database. This works on multiple machines for me.

See my screenshot below. If you are not on the latest 2904 beta build- I recommend that you install that.

TDPa.jpeg

Better resolution:

TDPa1.jpeg


#6

Jeff,

Thanks for the update. We will do more investigation on our side. We are using the latest version of beta (2904) on Windows XP. Here is what I see on my
side. Can you try with a tabbed view of the Object Explorer?

Panos Menelaou

AVP, Enterprise Information Services

SunTrust Bank

Direct: 404-813-4978

From: Jeff Podlasek [mailto:bounce-Jeff_Podlasek@toadworld.com]

Sent: Thursday, April 10, 2014 10:53 AM

To: toaddatapointbeta@toadworld.com

Subject: RE: [Toad Data Point - Beta Discussion Forum] 3.5 beta Defect - DB2 LUW MQTs error in Viewer

RE: 3.5 beta Defect - DB2 LUW MQTs error in Viewer

Reply by Jeff Podlasek

Panos,

Your screenshot did not post - please try posting that again.

Yes - I am successfully displaying MQ Tables using the latest beta against a v9.7 LUW database. This works on multiple machines for me.

See my screenshot below. If you are not on the latest 2904 beta build- I recommend that you install that.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad Data Point - Beta
notifications altogether.

Toad Data Point - Beta Discussion Forum

Flag
this post as spam/abuse.

LEGAL DISCLAIMER

The information transmitted is intended solely for the individual or entity to which it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of or taking action in reliance upon this information
by persons or entities other than the intended recipient is prohibited. If you have received this email in error please contact the sender and delete the material from any computer.

By replying to this e-mail, you consent to SunTrust’s monitoring activities of all communication that occurs on SunTrust’s systems.

SunTrust is a federally registered service mark of SunTrust Banks, Inc.

[ST:XCL]


#7

I still do not see any of your screen shots.

I tried this again with Tabbed, Multi-line tabbed, Dropdown, TreeList, Flat Tree and all work fine for me.

Just curious - How many different connections do you have open? I tried with 3 and have no issues.


#8

Jeff,

I am not sure why the screenshots do not get through. Please see attached Word document.

However, I have good news. I had someone install 3.5 beta on a machine that never had Toad before and the MQT issue does not exist. It works like you stated.
That gave me an idea and I did some cleanup and uninstalls on my machine and the other machine we had the issue and everything works now. I am guessing that there was something in the registry or a previous beta version we had that caused the issue. It was
not just the application directory since I had removed that in the past.

Thanks for the help and we can consider this resolved unless we run into it again.

Panos Menelaou

AVP, Enterprise Information Services

SunTrust Bank

Direct: 404-813-4978

From: Jeff Podlasek [mailto:bounce-Jeff_Podlasek@toadworld.com]

Sent: Thursday, April 10, 2014 3:11 PM

To: toaddatapointbeta@toadworld.com

Subject: RE: [Toad Data Point - Beta Discussion Forum] 3.5 beta Defect - DB2 LUW MQTs error in Viewer

RE: 3.5 beta Defect - DB2 LUW MQTs error in Viewer

Reply by Jeff Podlasek

I still do not see any of your screen shots.

I tried this again with Tabbed, Multi-line tabbed, Dropdown, TreeList, Flat Tree and all work fine for me.

Just curious - How many different connections do you have open? I tried with 3 and have no issues.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad Data Point - Beta
notifications altogether.

Toad Data Point - Beta Discussion Forum

Flag
this post as spam/abuse.

LEGAL DISCLAIMER

The information transmitted is intended solely for the individual or entity to which it is addressed and may contain confidential and/or privileged material. Any review, retransmission, dissemination or other use of or taking action in reliance upon this information
by persons or entities other than the intended recipient is prohibited. If you have received this email in error please contact the sender and delete the material from any computer.

By replying to this e-mail, you consent to SunTrust’s monitoring activities of all communication that occurs on SunTrust’s systems.

SunTrust is a federally registered service mark of SunTrust Banks, Inc.

[ST:XCL]