Toad World® Forums

6.0 dot lookup


#1

I’m still having problems with the dot lookup. it seemed to be hit or miss with me while using the betas. With 6.0, it doesn’t seem to be working for me. I click the Auto Code Completions/Dot lookup button on. Then in my query, I’ve tried typing the alias with a period and waiting about 10 seconds, and I have also tried pressing ctrl-space after the period. Nothing.

Then, when I press F9 to run the query, I get the following message in the Output, but the not up in the Grid error. Usually, with an error, it will show up in the grid area as well as the Output. then if i wait a couple of minutes, press F9 again (without changing anything), it runs, and this message disappears.

14:52:53 ORA-12612: Message 12612 not found; product=RDBMS80; facility=ORA

Thanks.
-Charlie


#2

I’m having the same problem with dot lookup.

jet


#3

Hi Charlie and Jet,

We are still checking it out for you with the dot lookup.

We could not reproduce the issue yet with our DB testing environments. We believe it might relate to the query SQL Navigator use to populate the list, if the DB is remote or there are very large number of objects, it would take sometimes to display the list…

We will keep you posted with more updates soon.

Hi Charlie,
Regarding the ORA-12612. Can you please use the SQL Monitor application to get the sql(s) running when you get this ORA error…It might relate to the dot look up issues you reported where the dot look up query still running on the background.

Thanks and regards,
Bruce

MessageORA-12612

TNS:connection is busy

Cause: Attempted operation failed because it conflicts with an ongoing

Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.

Oracle Product Document Library (C) Oracle Corporation
Manual: Oracle Database Error Messages
Reference: B28278-01

#4

Hi Charlie & Jet,

We have made a number of changes in the dot look up areas, tuning the queries to populate the list much quicker. Since we could not reproduce the dot look up issues you reported. Could you please check it out in build 1090 and let us know if you still have any issue with it.

Many thanks in advance.

Best regards,
Bruce


#5

Hi All,

On some DB environments, have the Enable Using DBA Views option selected in the Logon Window (attached dootlookup1) will stop the Dot look up working due to the query failed like in dotlookup2 attached screen.

If the login user does not have access to DBA Views, pls make sure that the ‘Enable using DBA Views’ option in the Nav logon window is not on.

Thanks,
Bruce
dotlookup2.jpeg


#6

Hi All,

On some DB environments, have the Enable Using DBA Views option selected in the Logon Window (attached dootlookup1) will stop the Dot look up working due to the query failed like in dotlookup2 attached screen.

If the login user does not have access to DBA Views, pls make sure that the ‘Enable using DBA Views’ option in the Nav logon window is not on.

Thanks,
Bruce
dotlookup1.jpeg