Toad World® Forums

6.3.0.1789: Deinstaller does not find sqlnav_6.3.0.1789-beta.msi


#1

Hi!

It seems that my installation is corrupt.
Is it possible to extract the .msi file from the installer exe to cleanly deinstall the beta?

Regards
Torsten


#2

Hi

How are you deinstalling? Are you using the Quest installer application or the windows add/remove programs?

Maybe you can try to install the 1824 over that old installation and then desinstall it and install it again?

Regards


#3

Actually I have used windows add/remove programs.
Installing 1824 over that old installation gives an error.
Removing with quest installer says that it has deinstalled.
But 1798 furthermore exist and is startable.
1824 installer comes with error 1638.


#4

Hi Torsten,

We recommend user to run the installation to install SQLNav and use Quest Installer to uninstall SQLNav. But as you have already used Windows add/remove to uninstall and had problem with new installation, yes we have provide the way to extract the msi from the installation file:
refer to the pdf install guide in page 2
http://sqlnavigator.inside.quest.com/shares/sqlnavigator/sbin/ReleaseNotes/6_2_1/SQL_Nav_Silent_install.pdf

Run any of the SQL Navigator bundles from the command prompt, adding the
‘/extract’ parameter:

Note: You will only be able to extract the MSI files that are contained within the
bundle you select. So be sure and use a bundle that contains the MSI files that
you require. In our example, we have used the SQL Navigator Development
Suite which contains the MSI files for all of the products.

Let me know if you still have problem with installing SQLNav.

Thanks,
Vincent


#5

I know this option before and have tried it without success, maybe because I have used this via vpn.
Have repeated this today in our lan and it works fine - thanks.


#6

Hi Torsten,

Do you still having problem to uninstall the previous beta?

Jeff


#7

No - deinstallation has worked now.