Toad World® Forums

6.4.0.1881: Ticking expression in run tab is difficult to undo


#1

Hi

When running a function from a package using the green run button.
A simple function with only one IN parameter and one OUT parameter.

I accidentally ticked the Exp check box. Then typed in a literal like CAT.
I received the error -

This is not a valid expression of type VARCHAR(32000)

  • which is fine and makes sense.

I then removed the text and tried to unset the Exp checkbox. Got the same message.
Then tried to set the Null or Def checkbox also getting the same message.

I then changed the expression to be upper(‘cat’) which is a valid expression and it was happy for me to then check the other check boxes and then I could also remove the expression text.

So there seems to be some over zealous validation going on.

I checked this with a few other functions and can reproduce the problem.

Thanks,
Adrian.


#2

Hi Adrian,

Thanks for your feedback. We will try to fix the problem in the next 6.4 Beta release.

Regards,
Roman


#3

Hi Andrian,

Thanks for reporting this issue. I agree it’s not user-friendly when you cannot use mouse clicking to exit the editing field. I will raise a CR for this.

When the error message is shown, you can use keyboard Esc key to exit the field then click at the other check boxes.

Thanks,
Vincent


#4

CR has been raised.

Regards,
Roman