Toad World® Forums

6.7.0.135 code auto complete not listing tables


#1

I’m not sure what changed with this version, but when I type

select * from

I used to get a list of table names. Now I get a list of field names that appears to be from the first table alphabetically.

Is this operator error on my part? I there a new setting a need to configure? Or is this a bug?


#2

Hi,

Sorry I cannot reproduce this issue. Could you please provide more details? Like screen shot or script?

We did make some changes for code completion.

For now, the code completion will show column right of the table name. As I know, there no other setting changes.

Best Regards,

Kelly


#3

I’ve tested on multiple database servers, some 2012, some 2008, one was even 2005.

Here is the screenshot.

Not sure what other details I can give you. The example is pretty simple. Whenever I type “select * from” I get a list of field names from the first table.

I tried typing “insert into” and the same dialog appeared.

Thanks,

Scott


#4

Hi Scott,

Thank you very much. Could you please try to drag the Left border to right? Or drag the code completion dialog more larger?

According to your screen, it seems the table list is hiding .

Best Regards,

Kelly


#5

Perfect, that worked. Sorry for being an idiot!