Toad World® Forums

Access violation error


#1

Error - Access violation at address 0090FEC3 in module ‘TDM.exe’. Read of address 00000000.

and

Access violation at address 1803211C in module ‘scriptproxy.dll’. Read of address 00000000.

These errors occur when doing almost anything in the application. When the Videorental model opens, if I try to edit an entity, generate a sql script, model verification, etc.

The application is unusable. I have tried on two different PCs with the same results.

Version: 3.0.1.451 from the download tdm3_002_beta.zip.
Windows XP Pro SP2.


#2

Hello,

I’m sorry to hear that you have such troubles with TDM 3 BETA.

Nevetheless, let me ask you what antivir program you use. We think this might be the problem.

Please check out if you have the same antivir program on both PCs, and try to install TDM3 on another computer (if it’s possible).
Please let us know the result. Thanks in advance!

Also, do you use Toad Data Modeler 2? If so, can you work with it - edit entities, generate SQL code etc. without any problems?

Thanks for your response.

Regards,

Vladka & TDM Team


#3

We use McAfee VirusScan Enterprise 8.0.0 patch 10.

This is installed on all of my company’s PCs, so I will try to build up an image on Microsoft Virtual PC to do beta testing.

I do not use Data Modeler 2.


#4

I have created a Microsoft Virtual PC image of Windows XP (SP2) with all patches available. No other software is installed on the Virtual PC. I then installed the TDM Beta. In this environment, TDM Beta seems to work fine. I am able to edit an Entity, generated SQL scripts, etc.

So this begs the question, will TDM ever work on my normal PC where McAfee is installed?


#5

Hello,

Thanks for all this information.

We will install this antivir program and will try to find out what causes the problems.
In any case, we need to ask you for patience. Thanks!

CR # 31 964.

Regards,

Vladka


#6

We also have the same enterprise virus scan Viruscan enterprise 8 and we have the same problem. Has this been resolved yet?


#7

Hi,

Has this been resolved yet?

Unfortunately, not yet.

We need to ask you for patience. Thanks very much!

Regards,

Vladka & TDM Team


#8

I also am getting the access violation error when interacting - moving, editing entities Specifically -
Access violation at address 00C41D20 in module ‘TDM.exe’. Read of address 00000000


#9

For what it’s worth, I have Symantic Antivirus Corporate 9.0.0.338 on my machine. Unfortunately, I find the beta to be unusable until this is resolved. (Currently I’m using the Case Studio 2 version for daily work and love it, but some of the TDM enhancements look great so I’m eagerly awaiting…)


#10

Hi Allan,

Thanks for your post.

For what it’s worth, I have Symantic Antivirus Corporate 9.0.0.338 on my machine. Unfortunately, I find the beta to be unusable until this is resolved.

Very sorry to hear this.

We’d like to solve this problem as soon as possible, however at the moment there are many other tasks with higher priority, I’m sorry.
I’m afraid, we need to ask you for patience again.

Thanks very much.

Regards,

Vladka


#11

ok, thanks for the reply. Will possibly try disabling the anti-virus or try on a different computer to see it this is the issue, as I am anxious to continue trying out this beta. :slight_smile:


#12

found the answer
http://modeling.inside.quest.com/thread.jspa?threadID=3293&tstart=0

short form:
**regsvr32 /u “c:\program files\network associates\virusscan\scriptproxy.dll”

cu**


#13

Hello all,

Here I’m with an update:

Latest BETA 3.0.6 has been tested on McAfee VirusScan Enterprise 8.5 and works properly. No problem has occured.

Please feel free to check it out. Thanks.

Vladka


#14

Good morning,

I am running version 3.006 Beta. I was trying to reverse-engineer an Oracle database. After I entered the database information, I did not save it when requested. Upon the depressing the next button, I got an access violation at address 18032110 in module scriptproxy.dll read address 00000000.


#15

Hello Marty,

Do you use McAfee VirusScan Enterprise 8.5? Or what antivir program do you use?

Vladka


#16

Hi,

I have used the version 3.0.11.11 with VirusScan Enterprise 8.0, patch 14, and after the ‘Model Update…’ I receive the same error.

I am using the trial version.

Do you have any suggestion?

Tks,
Everson


#17

Hello Everson,

Please read the whole thread on this issue.
See also:
https://knowledge.mcafee.com/article/778/KB40067_f.SAL_Public.html

In any case, TDM3 has been tested on version 8.5 and works properly.

I hope this will help a little.

Regards,

Vladka


#18

Hi Vladka,

I made those changes in my register, but did’t work.

Also, I tried disable VirusScan, but the problem still.

The exact message error is:

“Error - Acess violation at address 00DC3816 in module ‘TDM.exe’. Read of address 00000000”.

Tks,
Everson


#19

Hi Everson,

what changes do you have made?

Do you unregister the scriptproxy.dll?

Regards,
Tobias


#20

Hi Tobias,

No, I made the workarround 1, including 'ExcludedProcesses ’ in my register.

If I unregister the scriptproxy.dll, how can I register again?

Tks,
Everson