Toad World® Forums

Agent not able to start virtual users on remote machine

Hi,

I have installed BMF on Windows Server 2012 R2 and set-up a remote agent through console as suggested in BMF user guide on a remote PC hosting windows server 2012 R2.

I am able to connect to remote agent by changing the IP as suggested in a post in the discussion and console is able to detect and verify the remote agent.

However, when I am running a TPC-E workload, the local agent is able to start virtual users while the remote agent is shown as connected in console tab but unable to start any virtual users.

On the remote PC, in the agent window, it displays “Starting Virtual Users” and then connection time-out happens with below error:


TPC-E Job SF 10 User 60

Job Started

Starting Agent(s) on WIN-F45C2VOEF5E

Starting Agent(s) on 107.108.207.60

Started test Create Objects for TPC-E

Checking for existing objects…

Checking scale factor…

Scale factor check complete.

The loaded TPC-E dataset might have been modified. If a refresh/reload of the dataset is not performed errors may occur during testing.

Objects already exists.

Test completed successfully.

Started test TPC-E Transaction Mix

Checking scale factor…

The loaded TPC-E dataset might have been modified. If a refresh/reload of the dataset is not performed errors may occur during testing.

Scale factor check complete.

Agent(WIN-NSDCAUBUFLT) Error: ODBC Error (08001,2AF9) - [Microsoft][ODBC Driver 11 for SQL Server]TCP Provider: No such host is known.

Test cancelled due to errors.

Shuting down Agent(s) on WIN-F45C2VOEF5E

Shuting down Agent(s) on 107.108.207.60

** Job finished.

Total Time to perform the job:

Start Time: 11/28/2014 3:56:22 PM

End Time : 11/28/2014 3:59:12 PM

Elapsed : 0 Days 00:02:50.091


What am I missing?? Please suggest.

Note: I am able to connect to SQL server instance installed on console PC from remote PC. Also I am able to configure a system DSN using SQL server library. But starting agent on remote PC do not requires these things afaik. The console only needs to distribute load with the remote PC.

Looks like there might be a name resolution problem on the remote machine. For the SQL Server ODBC Datasource on the console machine is the SQL Server machine entered a name or IP? If it is a name, you could either change the name to the SQL Server IP or add the SQL Server name to the hosts file on remote Windows 2012 machine.

Hi Kevin,

Thanks for your comment. Now I am able to run agent on both the machines :slight_smile: :smiley:

But now there is one more issue :frowning:

BMF is using only 2-3% CPU on the remote machine while consuming 99.x % on the console PC due to which it is crashing and the tests get aborted.

I though that the user load will be distributed and hence the CPU utilization. But it seems console is taking more CPU for SQL transactions.

Any workaround for this ?

Thanks in advance :slight_smile:

On the console machine which process is taking all the CPU? Is the BFactory.exe or the Agent.exe?

If you are running the TPC-E transactions with no latency, which can be verified by looking at the Test Options - Transactions tab for the TPC-E Transaction Mix test. No delay tells BMF to execute the transactions as fast as possible, which would cause the Agent to have high CPU usage. You can slow down how fast BMF sends transactions to the test server by adding latency, typically think time latency, but remember that slowing down the rate that transactions are sent will also lower the TPS value since the server is doing less work in a set amount of time.

The more interesting thing is whether there is a network issue with the remote Agent. To tell if there may be a potential issue compare the transactions times between the remote Agent and the Agent on the console machine. Is there a big difference? 2-3% CPU with latency set to No Delay and with a user load of 60 seems low, especially if the server is performing the transactions quickly for the local machine.

A couple of other things to change/look at;

  • I would uncheck the box in Settings - Benchmarks dealing with checking the scale factor. This can slow down testing time

  • Verify that you have the SQL Server communication protocol set to TCP/IP on both the console and remote Agent machines. I have had issue using named pipes before.

  • You may want to separate the creation of the objects and the test itself into two jobs.