Toad World® Forums

Alter Script creation problems


#1

(TDM 3.4.14.6)

Hi,

I’ve been working with TDM for a while now, but till today I was not able to create an alter script successfully without having to manually change the script afterwards.

My process is that I create the model, then a create script is created with which the database is created. After that when I make changes to the model, I reverse engineer die original database again and create an alter script between the two. (Maybe my process is wrong)

Currently I’m sitting with a problem that the alter script is trying to drop a primary key, but the foreign key constraint still exists, so it doesn’t allow the script to drop the primary key until the foreign key is dropped first.

I’m ok with changing the scripts for now, but can this part of the system please be tested in full again for Oracle and MySQL Databases?

Thanks


#2

Hello Rudi,

We have verified the issue and it works fine for us. FK is dropped first, then PK is dropped. As we keep failing to simulate the problem, could you please send us your models where the problem occurs? Or at least parts of the models.

Please send both models to modeling@quest.com. Please write us which model is Left Model, which is Right Model, if you modify default settings in the Sync & Convert Wizard and other important info. Thanks!

We look forward to hearing from you.

Note: The process you describe is O.K.

Regards,

Vladka + TDM Team

Message was edited by: vladka - added note


#3

Hi,

I found the problem on my side… I reverse engineered a database where one of the developers created an extra PK directly in my Oracle database. I converted this database to MySQL, ran my Script that I normally run after converting and tried to create an alter script. This alter script tried to drop my Primary key in my MySQL database, but it only existed in my Oracle database.

Sorry for wasting your time with this one, my head was obviously struggling to keep track of all the databases.

Thanks again for ALL the help.

Best Regards


#4

Hi Rudi,

Thanks for letting us know. No worries. We’re happy it’s been resolved.

If you have any troubles with TDM/questions, please do not hesitate to write us. We’re here to help.

Regards,

Vladka + TDM Team