Toad World® Forums

Attribute/domain/etc. status and "apply" button


#1

I find it somehow confusing, that when I edit something through inplace editor, the status of object (for example attribute) changes even when the text/value was not changed. And if I cannot change something through inplace editor , I must EDIT it with “edit” button, but because of that status, edit is not possible. Everything is grayed out.

I think the status should not change if the value is not changed through inplace editor.

And I think it should be possible to edit attributes even when the name, label has changed.

I may change multiple values through inplace editor one after one without touching apply between, but I cannot combine it with edit through “edit” link. But it’s edit as edit. No difference.

The same and more confusing is when adding new attribute.
You click on add, new attribute is inserted with common name.
Then you have two choices:

  1. click on inplace editor
  2. open editor through “edit”.

Again, choice 1 means does not create any problems, but
choice 2 throws message box that the entity must be saved first. What for ?
In TDM2 it was possible to add entities through EDIT dialog box completely, before saving.


#2

Hello arki,

First, I would like to note that TDM3 works with modeless dialogs (unlike TDM2), which brings many many advantages.
For this reason, there is the status bar. If you create a new item (attribute, domain…etc.), you need to confirm creation of this new item before you start editing it.
Once you start editing it (in the frame or in the item dialog itself), you don’t have to confirm each change. For example, in the Entity form / Attributes tab, you can go through the attribute properties in the the Entity form grid one by one using the inplace editor or F2 / or you can open the Attribute Properties dialog, go through all the tabs, and confirm the changes finally.

I find it somehow confusing, that when I edit something through inplace editor, the status of object (for example attribute) changes even when the text/value was not changed. And if I cannot change something through inplace editor , I must EDIT it with “edit” button, but because of that status, edit is not possible. Everything is grayed out.

Once you are in the edit mode, you need to close it - confirm whether you like to save the change or ignore it. If you use inplace editor to edit an item, you cannot edit the same item via the Edit button at the same time as the item is being edited via the inplace editor now.

The same and more confusing is when adding new attribute.
There was a discussion on this topic. Please read the following thread:
http://modeling.inside.quest.com/thread.jspa?messageID=7018

Note: Please see the Help file | User Interface | Interface Layout | Status of Items in Grids topic.

Thanks for your remarks.

Regards,

Vladka