Toad World® Forums

AutoCompletion issue?


When writing a stored procedure or function in the editor, I’ve noticed that Toad won’t autocomplete the names of local variables, especially those beginning with an at sign(’@’). If I type 'set @ ', I was expecting the autocompletion dialog to pop up with a list of my variables beginning with an ‘@’. I know the freeware SQL Server version does (I just tested it to make sure), and if I remember back a year ago when I used Toad for Oracle, it does, too.

Actually, I’ve noticed a few other instances when the autocompletion had no clue what to offer in the way of suggestions. Sometime I get a list of users instead of columns names; stuff like that. And it goes back to the earliest days of the Beta cycle - I just never reported it. Seemed petty at the time, but now it’s annoying.

Also, how do I get a list of procedures to come up? If I type 'call ’ and wait, I get a list of every table and view (system and otherwise) AND a list of users. But not a list of functions or procedures. Maybe I missed an options setting?

It seems to me the autocompletion feature is not as robust as with the other Toad versions.


Hello ,Imolter.

It is not working fine with auto complete if I tried to type “set @”.But it is working fine when you are typing “call” or “execute” procedures automatically showing up and when typing “select” tables,views,functions is showing up also. I have create a issue report for “set @” statement and seeing if we can solve this problem.



Yes, I agree about the ‘set @’, but why don’t I get a list of procedures when I type 'call '? I get a list of tables and users instead. What’s different in your setup and options that shows you the procedures but shows me everything but the procedures?

If you send me your email address, I’ll send you screenshots. I didn’t put in a service request because this is not a fatal bug, but, for me, at least, it’s something that is working poorly.


It is working fine with ASE,IQ,SQLAnywhere .Would you like to send me your bundle information . The menu is Help ->> Support bundle