Toad World® Forums

Automated Testing Feature


#1

We are getting the attached pop-up every time we run a package. I’m sure it is a useful feature, but we don’t necessarily want to use it. How do we get this message to stop showing up. I did check the help and searched this forum and couldn’t find any information on this… We have some databases that are still at 8, I clicked ok and installed it on an 11 db, but if I close navigator and open it again for that 8 database and run, I get this again. Very annoying…

automatedtesting.gif


#2

Hi Dale

The Code Test Repository is not supported on an 8i database. You should get a message indicating this if you attemp to installon to this version. See attachment.

So this explains why you keep gettiong the message about installing a repository.

HOWEVER

You should only get this message if you select any button that appears in the Code Test Section.

When you select to run any object, and you execute it. You are taken to the run TAB.

The New, Manage, Run all Tests, and Refresh button under Code Test, are all enabled. If you select ANY of these buttons SQL Navigator will check for a Repository. If you dont select anything you should never see the msg you reported.

Running the oject by pressing F9, Execute button on the toolbar or Execute button under parameters should not cause this message to appear, UNLESS you have the ‘Auto-create test case after code execution’ option checked.

I cant think of any other reason why this message keeps popping up for you, Do you have this option checked?

Regards
Lidia


#3

Sorry my screenshot wasnt added, here it is.
CodeTest8iMSG.bmp


#4

Thank you, this is somewhat helpful, however, in the attachment all I do is change the drop down (select the appropriate procedure withing the package). Nothing is checked and I get the above pop-up…
automatedtesting3.gif


#5

Thank you, this is somewhat helpful, however, in the attachment all I do is change the drop down (select the appropriate procedure withing the package). Nothing is checked and I get the above pop-up…
automatedtesting2.gif


#6

Hi Dale,

We will check it out with our Code Test repository check routine again, and will provide you an update early next week.

Thanks,
Bruce


#7

Hi Dale

Yes you are correct!
Looks like we have a bug specific to 8i databases.
Whenever you select an entry point to your package we try to populate the test case list and therefore you get prompted with the Code Test Repository message.

We will fix this in one of the 6.4 beta builds for you and you can try it again.

Regards
Lidia