Toad World® Forums

AV, Preferences-> General -> Colors -> Syntax Colors


#1

Hi all,

Every single try to customize the Preferences-> General -> Colors -> Syntax Colors
ends with an AV. Honestly - every single time!
I was unable so set the Colors like they are in my 5.5.4. and as you can see from the screen shot.

Andre

AMei_600Beta_864_Bug_002.doc (90.5 KB)


#2

Hi Andre,

Thanks for your info. I tried to reproduce the error but everything was fine. I didnt get any AV at all. Is there anything you did before changing the Reference that can trigger the AV? Please give us some more info or steps to reproduce the problem.

Thanks
Gwen


#3

Hi Gwen,
except for the first time, the steps to try this was all the same:
Start SQLNavi and Connect to a Schema and immedeatly after that:
Preferences-> General -> Colors -> Syntax Colors

For example I could not manage to set the color red for brackets although in the preview show it so.

(My client is a Microsoft Windows XP [Version 5.1.2600])

If you need further infos, please let me know.

Andre

PS.
I’m sorry to say that, however I just noticed that for me the Beta give me an AV just when I open it (with a connection to an schema) and close it afterwards.
After every close I get this ugly AV.
Andre

Message was edited by: andreml


#4

I still coudnt reproduce the AV problem, both with changing preferences or open and close NAV. However, I did notice that it didnt change the color of symbols (bracket, plus sign…) as expected.

I will keep an eye on this and hopefully find out what’s wrong.
Sorry I can’t help you much here.

Gwen


#5

Good news!

I had the same problem this morning and Bruce managed to find out what went wrong. The problem has nothing to do with changing the Preferences.

The problem happened when I accidentally turned on the Task Manager. For some reasons, the Task Manager window didn’t appear. It was there but it wasn’t visible so I didnt dock it. The AV was caused by having that window floating.
We will fix this problem but at the moment my advice would be:

  • delete this registry:
    HKEY_CURRENT_USER\Software\Quest Software\SQL Navigator 6.0.0 Beta\Docking Windows
  • Make sure all the dockable windows are docked.

Hope this helps.

Gwen

Message was edited by: Gwen


#6

Hi Glen
in the attachment you can find the registry export file you have pointed to.
I have set all values to 1 for Autohide and Visible.
Afterwards I started the Beta and had a lot of windows that I could not move,but only close.
After closing these windows I closed the Beta and got no error.
However after playing a little bit more I found the following:
Whenever I have a output window open I’m getting this AV; if I close the outputwindows before I close the beta there is no AV.
I’m not sure whether this helps you much, but I would like to let you know.
(I remember that in previous versions there it happened, that you was unable toset the output window visible. The only chance to manage this was to choose another layer.
I have no idea if this is important for this issue.)

By the way, I’m not a friend of hacking in the registry, since it is a mystery forme at all. There are things you better never know if you want to be able tosleep well at night.

Andre


#7

Well,

I slept not really good last night, so please forgive me that I forgot to attache the file…
Here finaly it is.

Andre
SQLNaviBeta6_DockingWindows.reg (58 KB)


#8

HI Andre,

I’m not a big fan of the registry either. ;D

Anyway, I think the problem you got now is because you changed the values in the registry. Just go back to the one I stated above and delete that entry from the registry. After that, just make sure you dock all the floating windows in SQL NAV. BTW,The bug is fixed in the next build.
Gwen