Toad World® Forums

Beta 6.5.0.23 - Session Browser - The user does not have permission to perform this action.


#1

When I run Session Browser in Toad Beta 6.5.0.23 I receive a box with error message “The user does not have permission to perform this action.”

Then no data is shown in Session Browser.

But when I run Activity Monitor in Microsoft SQL Server Management Studio 2012 it works (the same user, the same database).

I do not have system administrator role, so my permissions are limited.

Here is a screenshot from Microsoft SQL Server Management Studio:

MSSMS.png


#2

Hi Chris,

I can reproduce your error if my user have not VIEW SERVER STATE permission, and so does SSMS. But when I grant the permission, open session browser , I get an another error

You do not have permission to run ‘SYS.TRACES’ ,But I can view the data ,We will fix this error(TSS-624)

Please try to grant the permission to see if you can view the data.

Thanks,

Cathy.


#3

I can confirm that:

-I do not have VIEW SERVER STATE permission

-I do not have access to SYS.TRACES

I am not a system administrator, and I am not going to have this permissions.

Nevertheless, without them SSMS works, but Toad does not.

If a user does not have some permissions, Toad should show all data available, not just give up on first error.

Currently, after an error Session Browser is completely empty:

toad.png