Toad World® Forums

BETA5: Extract DDL fails


#1

Find a package body in “Find Objects”.
Click on it and press CTRL+D.

All I get is 09:56:17 Invalid data type for ‘’ in the Output tab and no DDL is extracted.

This is happening also with other type of objects.


#2

64bit version


#3

Hi Martin,

It sounds like some data in your Preferences are corrupted. Could you run regedit and navigate to “HKEY_CURRENT_USER\Software\Quest Software\SQL Navigator 7.1.0
Beta\Preferences”? Please rename “Preferences” key to “Preferences_bak”. Then run SQL Navigator again to try extract DDL. Let me know if this helps or not. If this works, it would be great if you can export “Preferences_bak” and send it to us. We would like
to investigate where the error occurs.

Thanks,

Vincent


#4

Unfortunately it didn’t help :frowning:


#5

Sorry to hear that :frowning:

Did you see the error in output after or before Preferences dialog appeared? Does Extract DDL work in other places such as DB Navigator?


#6

No preferences dialog ever appeared .

The only thing is the error in the output:

ScreenShot110.jpeg

Yes, the same error when object is opened and select from toolbar: Object > Extract DDL…


#7

I am afraid you cannot open Preferences from view menu at all? Can you try it?

Here is a more thorough solution to clean up corrupted data:

  1. close SQL Navigator

  2. rename registry key " HKEY_CURRENT_USER\Software\Quest Software\SQL
    Navigator 7.1.0 Beta" to " SQL Navigator 7.1.0 Beta bak"

  3. rename folder “%appdata%\Quest Software\SQL Navigator 7.1.0 Beta” to “SQL Navigator 7.1.0 Beta bak”

  4. now start up SQL Navigator again

I hope this time it helps.

Thanks,

Vincent


#8

You’re right, I cannot.

In step 3 the folder was:

C:\Users<MyUserName>\AppData\Roaming\Quest Software

Yes, all the preferences were dropped and everything was fresh and new.

But no, it didn’t help to solve the problem.


#9

Hi Martin,

Could you send me the support bundle files from Help | Create Support Bundle files? Please send both prof and dta files to my email Vincent_Liu@dell.com.

Thanks,

Vincent


#10

Ok, but how can I create the “prof” files?


#11

Oh, it is created automatically and put right where the .dta file is :slight_smile:


#12

We thank Martin a lot for his assistance. The defect has been identified. SQLNAV-1671 is created for this issue. Anyone else who experiences the same error,
please run the reg script in attached zip file to work around this error.

Thanks,

Vincent


#13

Hi, I am having the same issue now. Where can I download the zip file?