Toad World® Forums

Bug in most recent Build RE: Alter Stored Procedure In Editor


#1

If I right click a stored procedure and edit it in the editor, then run the SQL
to make the alter to the stored procedure, I get an error in the output Windows

"Category Timestamp Duration Message Line Position

Error 5/17/2010 8:05:18 AM 0:00:00.031 SQL Server Database Error:
‘CREATE/ALTER PROCEDURE’ must be the first statement in a query batch. 7
0

This is in the most recent build.


Charles Haines
Senior Software Developer
P: (410) 535-5590 x1196

Recorded Books, LLC
http://www.recorded books.com


#2

What I did: On any stored procedure I right clicked, ran “Alter Stored
Procedure in Editor”, and executed the resulting script without any
changes. It ran successfully on 2000/2005/2008 and SQL Azure. I tried both 336
beta and the current dev build.

Any additional info? Can you post the image of the top part of the script which
failed in your case? Just the part from the beginning down to the ALTER
PROCEDURE statement if it’s possible?

Thanks,

Igor.


#3

Interesting, I just tried it and it appears to be working just fine now. I
swear it did it. Oh well, I guess it’s good to go now.


Charles Haines
Senior Software Developer
P: (410) 535-5590 x1196

Recorded Books, LLC
http://www.recorded books.com

On Mon, May 17, 2010 at 5:47 PM, Igor Manokhin
wrote:

What I did: On any stored procedure I right clicked, ran “Alter Stored
Procedure in Editor”, and executed the resulting script without any
changes. It ran successfully on 2000/2005/2008 and SQL Azure. I tried both
336 beta and the current dev build.

 

Any additional info? Can you post the image of the top part of the script
which failed in your case? Just the part from the beginning down to the
ALTER PROCEDURE statement if it’s possible?

 

Thanks,

 

Igor.