Toad World® Forums

bug:problem with '


#1

BUILD 825

Maybe you already know this one

  1. create a new procedure via DB Explorer->Procedures->Create New
  2. name it something (example aaaa)

If you put wrong number of ’
(…)
BEGIN
DBMS_OUTPUT.put_line(‘a’’);
END;
3a.At one time it did not create the procedure and clear the procedure edit window (so I lost the code)

3b.Most of the times it gives error and puts a ’ in the end of the file.
Now I know here the error is but with a big code (in a package) I found it annoying.

  1. Editing a package/procedure and producing the error gives the problem 3b.

BTW The usual shortcuts from SQL Nav 5.* are not working ?


#2

Hi Filipe,

Sorry for the delay. I’ll investigate the problem and come back to you tomorrow.

Thanks,
Roman


#3

Related problem:
When that occurs all the &***; I have in strings (like web codes, for instance   , & ,etc) are replaced (exchanged) by ;
This problem occured also in a previous SQL nav version (not beta), and I also reported it (not via forums, but by support link).


#4

Hi Filipe,

I couldn’t reproduce the problem in the development build. Moreover, the syntax highlighting (much improved in this build) shows clearly that there’s an unterminated string.

Speaking of the shortcuts, we are working on this. By the time we go GA, all the 5.5 shortcuts will be supported (where applicable).

Regards,
Roman


#5

PS. The ampersand problem has also been fixed.


#6

That means that you try to reproduce in another (developing) version, soo its fixed or that you could not reproduce due to same error of my report?

Thanks


#7

I didn’t try to reproduce this in the old build, but it definitely has been fixed since.

Roman


#8

The error still occurs in beta 7 (build 844)


#9

Its very easy to get it.
As I said start a new procedure editor
paste

PROCEDURE aaaaa
IS
BEGIN
DBMS_OUTPUT.put_line(‘a’’);
END;

click the “save to database” button


#10

Hi Filipe,

I was able to reporduce this issue in build 844, but
we have a long weekend here and Roman took a day off. :slight_smile:
He will look into this issue again soon.

Rgds,
Andrew


#11

As I said, this works fine in our internal build, not in 844. Many things have changed since. We should release a new build soon, let’s see then.

Regards,
Roman


#12

I’m sorry to report that I got the same error in build 864

Any one else besides Quest can test it and find if its only with my instalation?

(I have several Quest products installed in my computer)


#13

Hi Fillipe,

I tried to reproduce the problem with build 864 and it always behaves like what you stated in 3b. (error and put a ’ at the end) It is because there is no closing ’ so it just append ’ at the end to close off the string.

I tried a few time but i could not reproduce the case where the code is wiped off. Does that still happen to you?

Gwen


#14

Hi Filipe,

I’ve fixed this problem for the next build (this time for sure).

Regards,
Roman


#15

yes. It’s now fixed in the last beta.