Toad World® Forums

Bug When removing identity from a column


#1

I’m trying to remove an identity from a column. the column is a part of foreign key, but the table is empty as i erased the 2 rows there.

When I remove it, toad generates some heave sql script, I press ok and it says everything is OK.

Then I check and the identity is still there.
Tried refresh but it still there.

Checked on SQL Management studio and it was gone there…

So I decided to reconnect, got this:
System.NullReferenceException
Object reference not set to an instance of an object.
Stack Trace:
at Quest.Toad.DatabaseBrowser.ObjectPaletteControl.TrlUpdated(ITrl listtrl, TrlCollection trls, Boolean clear, Boolean done)
at Quest.Toad.DatabaseBrowser.ObjectPaletteControl.ReadTrl(ITrl trl, Boolean& displayExpandIndicator)
at Quest.Toad.DatabaseBrowser.ObjectPaletteControl.ReadTrl(ITrl trl)
at Quest.Toad.DatabaseBrowser.ObjectPaletteControl.<>c__DisplayClass9.b__3()

reconnected again , the identity was gone, but the 2 rows I’ve erase - were back…


#2

Hi Dani,

thanks for your report. Actually the issue is already fixed. I checked your case on the current build and now it works fine. You can check it in the next beta drop.

Best regards, Julia.