Toad World® Forums

build 1317, Editor Background Bug


#1

Hi,

As you can see (screen shot,editor window) the standard background is black now and not white anymore.
This is also different to the preview.

And still the exception color pref is not working.

Regards
Alex

Message was edited by: andreml


#2

Hi guys,

I can see something is not right with the ‘Space’ element. You can try to reset the preferences to fix this. I’m not sure about the exception though. Could you give more information about this please?

Gwen


#3

Hi Gwen,
please see the screen shot (from his original email to me) from alex.

I hope it helps.
Regards
Andre
Alex_Custom_Color_Prefs_02.jpeg


#4

Hi guys,

Thanks for the screenshots. The issue with background will be fixed soon.

About the bug with exception, we have done a fair bit of work to fix all the issues with syntax colour. In the process, we decided to hide a couple of elements due to techinicality issues and Exception is one of those. What we can do for now is make sure the color showed in the sample window is the same as the one in your code but you won’t be able to change the color for this element.
All of these elements including Exception will be brought back and thouroughly fixed in the future.

Gwen


#5

Hi Gwen,

BUG: Custom Color Preferences:

Situation: You have colored “Custom Color Preferences”. One Element uses the default foreground. The second element uses a defined color. Let us use as the foreground color blue. The third element uses another foreground color. Let’s take green.

Symptom: If you are moving through the elements by using the arrow keys you come to the first element. The foreground color is default. Now you move to the next element with the down-arrow-key. The foreground color of the second element is now shown as black and not blue. Now you move to the third element. The green color of the third element is shown correctly. Now we go back to the second one by using the up-arrow-key. Now the color of the second element is blue.

So, every time you come from the first element the color of the second is wrong (black). If you come from the third element the color is ok.

If you now set a foreground color for the first element the following elements has there right color too.

In my case I set Symbol to foreground default. The Marked Block has blue.

Best regards

Alex


#6

Hi Andre,

We would appreciate it if you can confirm that this issue has been addressed in our latest beta build.

Gwen


#7

Hi Gwen,
sadly enought the same thing happened today too after the upgrade to 6.2GA.
Well, seems to be to late to take care of it…

Regards
Andre


#8

Hi Andre,

I retested this case and it works fine for me. My first element is symbol (foreground set to default). My second element is comment (foreground set to blue). My third element is string (foreground set to green).
The script I was testing on looks like this

– testing color preferences
dbms_output.put_line(‘test’);
– end

However, there might be an issue if you migrate the settings from a previous version. This issue wasn’t fixed in 6.2 so you may have to try this work-around: restore the default settings and manually change the preferences again.

Hope this helps,
Gwen

Message was edited by: Gwen


#9

Hi Gewn,
I hope you remember that it has been promised that this bug would be fixed for GA …
To heck with it!
But:
"
However, there might be an issue if you migrate the settings from a previous version. This issue wasn’t fixed in 6.2 so you may have to try this work-around: restore the default settings and manually change the preferences again."

I do think this should be added to the 6.2 docu anr/or open issue list for all users downloading this version.
Otherwise I suspect that you will get a big mass of requests/questions regarding to this stuff…

Best Regards
Andre


#10

Hi Andre,

The issue with background changing has been fixed and tested in 6.2. I retested it this morning and it still works for me.

The only case that we thought might stuff this up is if the user migrates the preferences. This issue was included in our release notes for the 6.2 release.

If this wasn’t what happened to you, could you please perform the steps that were outlined in my last post and let me know if the issue is reproduceable? In the steps that you provided a while ago, you mentioned that the second element you were using was marked block. This element is a bit different to symbol, number, etc. It only works when you highlight a block of code so the background for it won’t change when you press up/down arrow.

Cheers,
Gwen


#11

Hi Gwen,

“…if the user migrates the preferences.”
Yes that’s exactly what I did - and what likely almost all other user will do…

“This issue was included in our release notes for the 6.2 release.”
Yep, that’s what I wanted you to do :slight_smile:

Thank you.
Andre


#12

I also had that issue in one installation and using the release notes workaround
(1. Open preference window, Go to Code Editor->General->Syntax highlighting, Change the Highlighting style to ‘Classic’, then close the Preference window.)
and restarting the program fixed it.

Now a problem: Using the Twilight style or Blue it appears that the style is not applied correctly: the selected line hides chars or the style was wrongly color coded.
But if I choose the colors after I choose the twilight and without changing anything make ok it seams that it corrects the selected line style (even if it style now appears as custom :frowning: )

Thanks


#13

Hi,

This issue has been logged in our system. Thanks for reporting.

Cheers,
Gwen


#14

hi

I didn’t check if it’s a reported situation
I got this using the classic syntax highlight then editing the colors and without changing anything pressing ok (the selection will be named custom)

in a code editor make a selection (highlight some code)
select another code editor
if you can see both at the same time the previous one will be blacked.
selecting the previous one doesn’t change that

Regards