Toad World® Forums

Cannot connect to SYBASE IQ 16: "Could not load the encryption DLL"dbfips16.dll""


#1

Hello everyone, I´m new in the forum and in using Toad and I have the following problem: when I´m trying to connect to my SYBASE IQ 16.0.0.429 server by Toad 3.1.0.315 in a windows 7 64bit lap-top I set all the right connection parameters but when I try to connect the following message appears: “Could not load the encryption DLL"dbfips16.dll"”, I can connect by InteractiveSQL but I really want to use toad, can someone help me with this error?

Thanks in advance and kind regards.

Omar Romero


#2

Hello Omar Romero,

Thank you for your post. The similar problem was already reported to us. We are investigating the issue in TSY-2035.

It seems that there will be a possible workaround for that. I’ll let you know as soon as we find the solution.

May I also ask you what is the OS on the machine running the IQ database?

Thank you

Libor


#3

Hello Libor,

Thank you for your comments, answering your question: I have two scenarios one is connecting to a local IQ installation on my own lap-top (Windows 7 64bits) and the other is connecting to Windows Server 2012 R2 Datacenter Edition 64 bits.

Kind regards.


#4

Hello,

Has there been any update to this issue? I’m getting the same error when connecting to Sybase IQ 16 running on Linux from a Windows 7 machine.

Thanks,
Eric


#5

Hello Eric,

We fixed the problem in TSY-2035. Unfortunately the fixed TSAP version wasn’t released yet.

Hopefully the fixed Beta will be released within few days.

However there’s a workaround: to get library dbrsa16.dll from Sybase SQL Anywhere ADO.NET client and put it to the same location as Toad.exe (C:\Program Files (x86)\Dell\Toad for SAP Solutions 3.1).

Libor.


#6

A new Beta is posted. Please download. This fix is in that version.

www.toadworld.com/…/


#7

Hello Libor

We also have the problem and I tried your workaround. I copied the libary dbrsa16.dll from the Sybase Client bin32 as well as from the bin 64 directory to (C:\Program Files (x86)\Dell\Toad for SAP Solutions 3.1). We still get the same error message. Toad is running on Windows and we try to connect to 64 bit IQ Sybase DB.

Do I have to restart the maschine ?

We already tried the Beta Version and it worked there.Unfortunately the Beta Version is only 30 days valid. thus we have to install the beta version every 30 days which makes not very much fun.


#8

Do you know when the beta version will be fully released ?


#9

Hello,

You don’t need to restart the computer, but you should restart Toad.

It’s also important to use the library with correct version and bitness. In your case (TSAP 3.1) this should be 32-bit version 16.0.0.2213 (16.0 SP46 Build 2213).

Libor


#10

Hello,

The TSAP 3.2 is available here: https://support.quest.com/toad-for-sap-solutions/3.2/download-new-releases

Libor