Toad World® Forums

Can't initialize OCI


#1

Hi everyone, I have installed SQL Navigator 6 and Oracle 10g database. Every time when I try to connect Navigator it shows the following error message: “Can’t initialize OCI Error -1, Make sure connection parameters are correct and try again”. Can anyone help me to solve this issue? Thank you so much.


#2

I Googled it and almost everything I found is pointing to it being a TNSNames Problem.


#3

Can you log in with SQL plus? Any more information would be appreciated.

Gwen


#4

It is not quite clear how did you configure Oracle?

For instance, if you did not instal SQL Nav 6 and Oracle 10g database (Oracle server) on the same machine then error message is straightforward. You need to instal Oracle client. From my support experience, this error always pops up when no Oracle software is installed on the PC with SQL Navigator.

Next possibility - you installed first SQL Nav a then Oracle. Although there is not specific requirements for installation order, usually users instal SQL Navigator after having Oracle client (or server) installed on their machines. In such case, a simplest way to fix it, could be re-installation of Nav.

If this will not help, we need to know more about your Oracle configuration and environment

Rgds,
Andrew


#5

Hi,
Could you please send us the Support Bundle files.

Please do the following:

  • Run SQL Navigator
  • Under Help menu item, select Submit feedback
  • In Submit Feedback windoow, check Include Preference box, click Save to File.
  • Please specify the location where you want to save the support bundle files.
  • Please send us the SupportBundle.dta, and Supportbundle.prof. The 2 files (text format) contains information of your environements, Oracle client, home…

Thanks and regards,
Bruce


#6

Hi,

If anyone having this error, please try to “Run as administrator” or disable UAC (required restart)

Cheers,
Jeff


#7

What does disable UAC mean?


#8

UAC: http://en.wikipedia.org/wiki/User_Account_Control


#9

Apply to Windows 7 , Windows Server 2008 and Vista:

Control Panel -> User Accounts -> Change User Account Control settings and change to Never notify