Toad World® Forums

Capture and Replay Problem


#1

I have been working on capturing and playing back workloads. I tried a simple test where I captured a work load consisting of several select statements and was able to play it back successfully.

Next I captured 20 minutes of users testing their application. The capture went ok but when playing it back it fails with the following error :-

ORA-06550: line 1, column 7:
PLS-00306: wrong number or types of arguments in call to ‘DESCRIBE_PROCEDURE’

Any ideas as to how I would get past this problem ?

Thanks,

Jim.


#2

DESCRIBE_PROCEDURE uses custom datatypes NUMBER_TABLE and VARCHAR2_TABLE which BMF do not support.


#3

Hi Kevin,

do you know where the DESCRIBE_PROCEDURE is coming from in the trace file ? Is it the Oracle optimizer which generates this ? I’m fairly sure that it is not the application that is calling that procedure.

Do you know a way around this problem ?

Thanks,

Jim.


#4

Without seeing the trace file(s) I wouldn’t be able to tell. If you know that your application does not call that procedure, you would be safe in just deleting the entire user scenario from the imported test.


#5

please Jim…can you told me if you enable something to get on all transaction in your trace file???

because i capture workload from trace file and show me that there in no transaction in trace file …although i run some simple transaction

Thanks


#6

Further information would be required to be able to tell you why the replay creation is showing no transactions in trace file, but here are a few things to check;

  • Make sure the user account running the simple transaction is not being filtered out by the setting in the filter page of the capture wizard. Such as connecting as SYSDBA or the SYSTEM user. Or running the transaction through Toad. Below is a screenshot of the default filter settings.

Filter page.jpeg

  • Make sure that the connection used to run the simple transaction was made after the capture was started. This is done to avoid an Oracle issue with incorrect dependency levels being listed in the trace file and therefore generating an incorrect replay.

  • Make sure you the simple transaction access the schema as selected in the capture wizard.


#7

thanks for your reply

you mean during capture workload from BMF, we made transaction trough toad to get on all transaction was run during capture workload from BMF


#8

Yes, when you capture from BMF transactions from Toad are filtered out. (see filter page screenshot above). To capture the transactions from Toad you would need to remove the %Toad%, %Dell, and the Quest% filters.