Toad World® Forums

Code Coverage feature not working?


#1

Hi CodeTester-Team

Recently, I tried to use the code coverage feature for my unit tests, but unfortunately it’s not working since I always get this runtime error:

Runtime Error:
Code: -918 System Error
Details: ORA-00918: column ambiguously defined

ORA-06512: at line 1
ORA-06512: at “UNITTEST_OWNER.QU_RUNTIME”, line 2064
ORA-06512: at “UNITTEST_OWNER.QU_RUNTIME”, line 2087
ORA-06512: at “UNITTEST_OWNER.QU_RUNTIME”, line 2135
ORA-06512: at “UNITTEST_OWNER.QU_RUNTIME”, line 2308
ORA-06512: at “UNITTEST_OWNER.QU_RESULT_XP”, line 5042
ORA-00918: column ambiguously defined
ORA-06512: at “UNITTEST_OWNER.QU_TEST”, line 1594
ORA-06512: at “UNITTEST_OWNER.QU_TEST”, line 1646
ORA-06512: at “UNITTEST_OWNER.QU_TEST”, line 1675
ORA-06512: at line 4

If I uncheck this feature, everything works fine again.
Is this an already known issue and fixed in CT2?

Thanks

Daniel


#2

DBMS_PROFILER is needed. Do you have the DBMS_PROFILER tables in your schema (PLSQL_PROFILER_RUNS etc)?
Install them (or let them be installed) by running ORACLE_HOME/rdbms/admin/proftab.sql

Worked for me!

Regards
Uwe


#3

Daniel,

  1. Yes, this is fixed in CT2.

  2. We can provide a patch for you to get this working in 1.9.

SF


#4

Hi Uwe

Thanks for your reply. Indeed, I haven’t installed the needed tables.
Anyway, if there are tables missing to fulfil some functionalities I asume at least to get an appropriate info or warning message :slight_smile:

Now the tables are set up and I don’t get a runtime error but in addition, I also don’t get any values for the code coverage (%). Also the reports are not working.
When I query the profiler tables manually it seems like all the data is available.

Regards
Daniel


#5

Hi Steven

A patch would be nice - where can i get it?

Many thanks in advance

Daniel


#6

We need to set up a ticket with Quest Support and then they will provide you with a patch (or I will), but best to go through the “process.” Can you do this?