Toad World® Forums

code editor - long lines "jump"


#1

When editing a long line (say 400 charachters) - scroll to the middle, so some text is hidden in the right and some in the left. Click in the middle of the text. Start typing. The first character scrolls the screen again so that the cursor is in the end of the screen. So the line is scrolled away, i can’t see what’s behind the cursor, and i scroll, and when i type again, it all happens from the beginning.

Andres


#2

Hi Andres,

I tried to reproduce the problem but I can’t. If I skip the step ‘Click in the middle of the text’ then yes, typing a character takes me to where the cursor was previously, which is the right behavior. Mouse scrolling doesn’t change the cursor position, only scrolls the text, and this is the standard behavior for all Windows applications. Or maybe I’m missing something?

Thanks,
Roman


#3

Best I can say is let’s compare Nav to Textpad (Another text editor I use). If I get a long line textpad will shift to where there is about 25 to 35 chars past where I am typing, so it moves in sections. Nav will move 1 char at a time causing the screen to appear it is jumping. (there have been other odd behaviour for long lines, honestly if I’m working on code with long lines I move to textpad because nav is very disconcerting), I can lose my place very easily in nav on long lines (Just my 2 cents worth).


#4

No, the click (cursor position) is very important.
It seems, that the long line shouldn’t be the only line. And it also seems, that the text shouldn’t consist of only long lines.

Now i tried this: two lines - a short select and a looong comment (all on one line)

select * from dual;
— extremely long line that has its text repeated 4 times— extremely long line that has its ddddtext repeated 4 times— extremely long line that has its text repeated 4 times— extremely long line that has its text repeated 4 times.

Now position the text so the horisontal scrollbar is in the middle, click in the middle and type. Jump.

If you copy only the long line or the long line twice, it doesn’t happen. So i assumed falsely it would happen every time.


#5

Hi guys,

I had a look and I can reproduce the issue. Strange enough, it doesn’t happen if the long text is on the first line. I will raise a CR for this.

Gwen