Toad World® Forums

Column Names don't display


#1

If you have N&D or N selected and the column name is sufficiently long, the whole name doesn’t display in the sql grid.

Jet


#2

the maximum length of a column name is 30. I tried to create a column whose name is 30 character long and the data grid displays the whole name correctly. Any more hints?


#3

Gosh, this isn’t hard to duplicate for me.

I jsut do a select off of all_objects and the “SUBOBJECT_NAME” column comes up “SUBOBJECT_NA…” every time. It doesn’t do that for you? I’m using build 879 (which expires 3/30 BTW)

Jet


#4

I tried that and nothing happened. The column is displayed correctly. I’ll keep an eye on this just in case.

Gwen


#5

I’m quite sure we’re doing something different.

We still need to set up the web ex so I can show you what I’m doing for a couple of issues that you can’t duplicate.

Jet


#6

Hi Jet,

It turns out that we have to go through Support to set up web ex which will take a really long time. If possible, could you please capture the process (from the time you start SQL nav) in a video and send it to me?

Thanks
Gwen


#7

Ok, playing with it a little further. Looks like you have to run a query with “D” or maybe “Def” first and then change to N&D or N to get it to display this incorrect behavior.

Can you duplicate that?

Jet


#8

Sorry Jet, no luck here! We are going to give another build for the community soon. By the end of this week. You can try it out and see if the problem’s still there.

GWen


#9

Problem still exists. :frowning:

It’s really consistent, I can’t believe no one else is seeing this. What font are you using for your query? I’m using Courier New 8. Maybe that has something to do with it.

jet


#10

I tested on several machines and none of them has this problem. I’m using courier new 10. I did try to change it to courier new 8 but nothing happened either.

Gwen


#11

We’re not looking at the same thing. Something is different cuz it happens ALL the time for me.

I’ll see if I can be more specific in duplicating when I get the time.

jet


#12

Hi Jet,

By any chance, aren’t you using Large Fonts in your Windows Display settings?

Thanks,
Roman


#13

I don’t think i am. I’ve attached my preferences so you can take a look. Maybe it will help you duplicate the problem.

My data grid is Tahoma 8. Could it have something to do with my monitor settings or anything like that?
joethejet.pref (3.32 KB)


#14

I tried your preferences, no luck. Can you send a screenshot?

Roman


#15

Attached
col_name_error.jpeg


#16

Did you try widening the columns and seeing if the name displayed? When I narrow my columns, I can cause “column_name” to be displayed as “col…” or whatever.


#17

Yes.

The problem is that with the D&N selected I shouldn’t have to do that.

Jet


#18

Hi Guys,

Near as I can tell this is working now EXCEPT for the row number column.

also, anyway to freeze the row number column so that you can select the whole column without having to scroll back to the left? It’s hard to keep the correct row in sight.

Thanks,

Jet


#19

Hi Joe,

We tried to implement this (fixed row# column), but unfortunately it brought some undesired effects (because of a bug in the component), so we decided to disable it for now. Maybe in the future…

Regards,
Roman


#20

One more thing that I just noticed. If you run a query with a large number of rows, Nav will change your column display from “N&D” to “Def”. When doing this, the row number has the same problem you used to have with all columns.

Jet