Toad World® Forums

Commit Error


#1

When I use the “green checkmark” to commit I frequently get:

10:46:10 AM line parameter must be array with length 32512


#2

Hi Joe,

I did many commits to test this but I dont see the error.
Perhaps the issue depends on the data type you are trying to commit.

Can you give me DDL for 1 table where you have seen this error and I will test with that.

regards
Lidia


#3

yeah, I’m not sure it’s a commit error per se, I think it happens after something else happens and then the commit thing occurs.

Maybe this will help. From Error.log

v7.0.0 2012-11-09 15:42:22 Access violation at address 00D98076 in module ‘sqlnavigator.exe’. Read of address 00000000
v7.0.0 2012-11-12 10:48:17 Exception Exception in module sqlnavigator.exe at 003EDF16.
line parameter must be array with length 32512.


#4

Hi Joe

Is it possible that you are somehow losing your connection to the database you are working with?

Lidia


#5

Not unless it is reconnecting on its own. I’m not having to reconnect.


#6

Ok, this seems to happen every time.

If I run a select with a writable grid, and then click the green check mark, I get

1:36:45 PM line parameter must be array with length 32512

If I click it again, I don’t get the error.


#7

Hi Joe

I have tried to test this on various window versions, 10g, 11g databases and client versions and i do not see this issue.

Can you please send me DDL of 1 table you have seen this on.
It may be a certain type you are trying to commit data too.

Also which commit icon are you selecting is it the one directly on the grid (hint says commit transaction) or the one in the main toolbar (hint says commit all pending changes to session)?

Lidia


#8

CREATE TABLE test1 (one NUMBER);
SELECT * FROM test1;

I press the blue + button, enter a number, hit enter. click on the green check mark.


#9

Hi Joe,

We can reproduce this error when having server output option on. PT40505049 has been created for this. We will fix it before next beta goes out.

Thanks,
Vincent