Toad World® Forums

Connecting ASE 12.5.4 (SunOS 5.10): Input string was in incorrect format


#1

Dear all,

I need your help to access my Sybase ASE 12.5.4 (from Solaris 10) with Toad for Sybase. Everytime I try to connect to the server, I get a Toad exception saying Input string was in incorrect format.

Call stack looks like:

System.FormatException

Le format de la chaîne d’entrée est incorrect.
Stack Trace:
à System.Number.ParseDouble(String value, NumberStyles options, NumberFormatInfo numfmt)
à System.Double.Parse(String s)
à Quest.Toad.Sybase.Trl.TypeListTrl.GetTrls()
à Quest.Toad.DatabaseBrowser.ObjectPaletteControl.DefaultType(ITrlList typelisttrl)
à Quest.Toad.DatabaseBrowser.ObjectPaletteControl.updateContentTimer_Tick(Object sender, EventArgs e)
à System.Windows.Forms.Timer.OnTick(EventArgs e)
à System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)
à System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

I works well with SquirrelSQL client.

Would you have any idea of where the problem comes from please?
Thanks for your help

Regards,


#2

Eventually found my answer in this topic: www.toadworld.com/…/22983.aspx

I’ve had tried just with changing the language is the taskbar and never really changed the format in Region and Langage. Now it works.

Although, would there be any solution to get it working with the French format in Region and Langage ?

Thanks for your help.


#3

Hello,

thank you for your post. I went over your problem and we already fixed this problem few months ago. Problem number was TSY-557 and you can see original topic here. If you want you can try our latest Beta to see if your problem is completely solved.

Thanks

Filip