Toad World® Forums

Connection error with ASE 15

I am using Toad for Sybase 2.1.0.2921, trying to connect to Sybase ASE 15.0.7.

I can connect from my Windows 7 machine successfully using the Sybase command line utilities (isql etc), or using the jConnect JDBC driver.

However when I try to connect using Toad to any of a number of different servers I get the following error:

“Connection to Sybase server has been lost. Connection died while reading from socket. ERRNO returned 0. All active transactions have been rolled back.”.

Unfortunately I am in a corporate environment where I am unable to use network tracing tools such as Wireshark. We are not using either SSL or Kerberos.

Is there any way to debug what is going on, or does anyone know what is the likely cause of this error.

Many thanks,

Robert

Hello Robert,

it is hard for us identify the cause of your problem. Seems that there might be some problem with your firewall or network than with Toad.

Message error which you see is not from Toad but comes from server. It means that some packet goes through but then are blocked. Can you check your firewall settings and if Toad is in Allowed Programs?

Thanks

Filip

Hi,

Thanks for your reply.

I have done some further analysis, which isn’t entirely conclusive however I really don’t believe there is a firewall problem. Some key facts:

  • I can connect to the same servers using JDBC or Sybase command line tools (isql). This demonstrates that there is no network issue between my machine and the Sybase server

  • I can connect to Sybase 15.7 instances using Toad. The instances I cannot connect to are all Sybase 15.0.3.

Are there any known issues connecting to Sybase ASE 15.0.3?

Thanks,

Robert

Hello Robert,

I tried it with same version of Toad 2.1 to same version of ASE 15.0.3 and I am still not able get any problem.

Can you try it with our latest version of Toad for SAP Solutions 3.0?

I suggest to also try some other machine so we can exclude that problem is not in your system.

Thanks

Filip