Toad World® Forums

Copy from a large text field in the grid


#1

If you do a Ctrl-c (or a right click copy) on a large text field (e.g. 255) in the grid, then you paste into your sql editor, it blank pads out to the entire column instead of just pasting in the characters that are in the field.

Jet


#2

I have a field that is a varchar2(2000) with a total of 280 chars in the field, I right click copy and then paste in both a different application and an editor in navigator and both only paste the characters in the field (I don’t get any spaces). I guess I don’t quite understand what it is you are doing to get the spaces…


#3

Not sure what the difference is, but if I do a right click or a ctrl-c I get tons of blanks when I past into the editor. It doesn’t happen when I go to word or wordpad.

If I open the pop up it doesn’t do it.

I’m using 6.0.0.1055

Jet


#4

Have you tried turn off the option “Trim column width while pasting” in Preference>Code Editor>SQL Scripts?


#5

Ah, that’s it! I’ve never seen that option before.

Thanks.