Toad World® Forums

copy/paste tabs


#1

There’s something funny about the tab size in the first tab of a session. (A little hard to explain because I’m talking about two different tabs.)

If I open a new connection, and copy and paste code that contains the tab character into the first tab, SQL1, it seems to default the tab size to 8 characters, even though I have it set to 3 in my preferences.

But then, if you open a second tab, and paste the same code, the tabs are the correct size.

See my attachments, both have the exact code pasted into them.

Thanks.
-Charlie

sql1.jpeg

sql2.jpeg


#2

Hi Charlie,

I haven’t been able to replicate this…
Can you send me a screen grab of your ‘Code Editor preferences’, so that I can see what you have the various ‘tab’ preferences set to?
This may hel me to replicate it.

  • Jaime -
    pref.jpeg

#3

Attached is a screenshot of my prefs.

What you need to do is in another editor (outside SQL Nav), create a simple statement using Tabs instead of spaces. Then copy and paste it into SQL1, then open a new tab, and paste it into SQL2. They will be different.

Thanks.
-Charlie
prefs.jpeg


#4

Yep… got it now Charlie.
I’ve raised a CR (with a nice video clip for Roman).

  • Jaime -

#5

Good pick-up. Note also that after you change the tab size preference, it only affects newly created tabs. I’ve fixed that already, along with your problem Charlie.

Roman