Toad World® Forums

Copying data from Grid to Excel


#1

I have been using the Ctrl+A, Ctrl+C method to copy data from grid to Excel and it all worked fine, however (with no specific reason) this method does not work anymore.

Instead when I do this all the data from columns are copied into one Excel column without beeing separated etc. Earlier the columns were preserved and it was an easy task.

Any idea how this can be fixed?


#2

I don’t know any setting that effect Ctrl-C . But you should be aware of some side effect of it. If your dataset is more than 1000 rows we return only first 1000 rows by default and only these rows would be copied in your case.

I would suggest using Export or Quick Export menu items to copy result set into Excel. The Export menu opens a wizard and give you more control over the copy. The Quick Export allows you to do a job very easy. To do it please click on a grid; right click to see the context menu, select Quick Export and Excel Instance. You have full control where to put the data.


#3

One of our developer suggested that the issue could be cause by Excel setting. Could we check it out?

To do it you’ll need to export a dataset to CSV file. You can do it by using Quick Export| File| CSV File. The file name by default will be CSVFile_Data_Time.csv and it will be saved in your Document folder.

Open the file with Notepad. Don’t open it by double clicking on the file because on this case the file will be opened in Excel. When you open the file in Notepad try to copy the data to Excel using Ctrl-A and Ctrl-C. Is the data coped correctly?


#4

I have the same issue - with toad for mysql 6.0.1.1723, I can copy the results from the grid and paste them straight to excel, and with a higher version (I think last I tested was 6.2), this no longer works


#5

I created the CR 104824 to track the issue.