Toad World® Forums

Copying test suites


#1

Hello,

I need to copy all of my existing test suites from one development database into a new development database. (We are using version 1.8.0.137) I have attempted to export the suites (or even individual tests) from the existing database, then import the resulting output into the new database. I have not had success, and I receive error messages stating that I do not have execute permission on the program, or the program does not exist. (As it is a new database, the program will not exist until it is imported.)

Please let me know if there is a reasonable method of copying my test suites from one database to another.

Thank you!


#2

There are a number of bugs in the export facility of 1.8. We fixed these in 1.8.1, which is available in beta form now, but will be available in production within two weeks.

I strongly suggest that you do the following:

  • Do an Oracle export of your Code Tester schema, as a backup.
  • Upgrade to 1.8.1.
  • Then perform the Code Tester exports.

When you export be sure to specify:

Set export owner to
(o) Schema into which the test definition will be imported

As for this statement: “(As it is a new database, the program will not exist until it is imported.)”

I am afraid I do not really understand. Importing a test definition does NOT import your source code. You have to do this yourself.

Please let me know how it goes.

Steven
Steven.feuerstein@quest.com


#3

Hello,

I recently upgraded to 1.8.1 and attempted to export my tests. I received the following:

ORA-24817 Unable to allocate the given chunk for current lob operation

I was sure to set the export owner per your instructions.

Is this a known bug? Do you have any suggestions as to how to avoid this bug. If this is a bug, do you know when it might be fixed? Note we are unable to send a support bundle.

Thank you for your assistance!


#4

Bill, this is not a known bug. Please report this to Quest Support. Some initial questions, though from me:

  • Why can you not send a support bundle?
  • What version of Oracle are you on?
  • The subject line is “Copying test suites” - are you trying to export an entire suite? If so, can you export an individual test definition?
  • Can you create a very small test definition (say of a schema level procedure and one elapsed time test)?

Thanks, Steven Feuerstein


#5

Hello Steven,

We are a government contractor, and our code cannot leave our building. Therefore, I cannot send ANY bundles and I am very limited to what can be sent. We are using Oracle 10.2.0.2.0. I may be taking the wrong approach. What happened is that we have CodeTester suites in one database. We created a new database to start development of a new version of our code. I wanted to export the existing tests into the new database. All of the stored procedures being tested and data structures are the same on the new database. I have tried to export the entire suite, as well as individual tests. I have some success exporting individual tests, but I do not have success re-importing them. I have tried exporting the entire CodeTester user, then re-importing. This gives me all of my tests, but they are all invalid and when I attempt to run any test, I receive unique constraint violations on qu_runtime and qu_harness_xp. Any/all suggestions would be greatly appreciated.

Thank you for all of your assistance and patience!


#6

Bill,

Have you upgraded to 1.8.1? That should fix the export bugs you are experiencing. As I said before, we did identify a number of bugs and repaired them. Did you take the steps I listed in my original response?

SF


#7

Yes, I upgraded to CodeTester 1.8.1. I also followed your steps. Any additional thoughts/suggestions would be greatly appreciated!


#8

OK, let’s recap:

  1. You installed 1.8.0 and created some tests.
  2. You exported to then import into a different instance and you get errors.
  3. You then upgraded your original 1.8.0 to 1.8.1 (where you created your test cases).
  4. You then exported from the 1.8.1 environment and you still could not import into the other instance.

Is this correct? If so, then two things:

a. Please check out the “Troubleshooting problems with Export/Import” document at:

http://unittest.inside.quest.com/kbcategory.jspa?categoryID=141

b. Please send directly to me steven.feuerstein@quest.com any bug reports or details you can provide.

c. Best of all, report the bug to Quest Support.

SF


#9

Hello Steven,

Per your instructions, I sent e-mail with some more details. I was able to work-around this issue, so this item can be closed.

Thank you again for all of your assistance and patience!