Toad World® Forums

Copying to clipboard values from grid


#1

Hi!

When you copy to clipboard(ctr+c) values directly from grid node, value has ascii(10) char (Enter) at the end.
Maybe this value could be trimmed ???

Regards Piter


#2

Hi Piter,

There is a preference to control this. Code Editors->SQL Editor-> Trim column width while pasting. Could you please check try again with this option on and see if this would work for you?

Thanks,
Bruce


#3

Hi Bruce!
I had this option selected, but afther deselecting and then selecting it works!

Regards Piter


#4

One more message!
Afther reopen sqlnav it still not works, option is checked


#5

I know now, when i select cell using narrows it works properly, but when i use mouse not.

When i select more than one cell, even by arrows, option not working.

Maybe it’s not problem with trimming while copying to clipboard, but there is “auto go to next line”( Ascii Enter) , afther pasting.

Check on your system

Regards Piter


#6

Thanks Piter for the info. I could not reproduce the problem with selecting using both mouse click and arrow keys. Will check with the team next week and will get back to you with more info.

Thanks and regards,
Bruce


#7

Hi!
Just for sure, a’m copying value directly from grid, without dblClicking yo open value window.

Regards Piter! Have a nice weekend!


#8

Thanks Piter for your note.

Have a great weekend too Piter.

Regards,
Bruce


#9

Hi!
My steps to reproduce.
Trim is checked in preerences.

  1. f3 on table
  2. Click on cell to copy
  3. ctrl+C
  4. ctrl+M and ctrl+v

When you use right click and copy value is trimmed. When you select cell by mouse and ctrl+C value is pasted with enter.

Regards Piter


#10

Hi Piter,

I jsut remember now that last week Bernard has worked on this similar issue with one of the case reported from a customer. I will ask him to get back to you this tomorrow.

Thanks and regards,
Bruce


#11

Hi Piter,

Thank you for your detailed steps and feedback. This inconsistency in behaviour will be addressed in a future build.

regards,

Bernard


#12

CR has been raised for this.

Jaime