Toad World® Forums

Create Credential Error


#1

Hi,
when I tried to chose identity when Creating credential, I got
following error:

System.NullReferenceException
Odwołanie do obiektu nie zostało ustawione na wystąpienie obiektu.
Translation: A reference to an object not set to an instance of an object
Stack Trace:
w Quest.Toad.SqlServer.Doe.Utils.DoeUtils.GetServerName(IConnection connection)
w Quest.Toad.SqlServer.Doe.Utils.ADPicker.ADPicker.RunDialog(IConnection connection, IntPtr intptrHandle, String previousValue)
w Quest.Toad.SqlServer.Doe.Credentials.CredentialsEditForm.OnBrowseButton(Object sender, EventArgs e)
w Quest.Toad.SqlServer.Doe.Credentials.CredentialsEditControl.Browse_Click(Object sender, EventArgs e)
w Quest.Toad.SqlServer.Doe.Common.Controls.TextBoxAndButtonControl.RaiseOnButtonPressEvent(Object sender, EventArgs e)
w Quest.Toad.SqlServer.Doe.Common.Controls.TextBoxAndButtonControl.btnBrowse_Click(Object sender, EventArgs e)
w System.Windows.Forms.Control.OnClick(EventArgs e)
w DevExpress.XtraEditors.BaseButton.OnClick(EventArgs e)
w DevExpress.XtraEditors.BaseButton.OnMouseUp(MouseEventArgs e)
w System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
w System.Windows.Forms.Control.WndProc(Message& m)
w DevExpress.Utils.Controls.ControlBase.WndProc(Message& m)
w System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
w System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
w System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Butter


#2

Hi Motyl,
I can replicate this issue on current Beta build, but this works fine on the same host on commercial builds for 4.6, 5.0.2, and current 5.5 development build.
I have no idea why this reproduces only on Beta :slight_smile: Can you please try on next Beta build and get back to me with your findings?

regards,
Alexander Maximov


#3

AM> Hi Motyl,
AM> I can replicate this issue on current Beta build, but this works fine on the
same
AM> host on commercial builds for 4.6, 5.0.2, and current 5.5 development build.

AM> I have no idea why this reproduces only on Beta :slight_smile: Can you please try on
next Beta
AM> build and get back to me with your findings?
Sure I can. Do you have any repository of such request / issues [I can view] ?
I generated few :wink: posts recently


Butter


#4

Unfortunately, we currently don’t have such type of repository publicly
available but we try to track all requests even if we don’t answer to
every single one. Also, we usually post the list of major issues resolved in the
beta’s Release Notes.

Igor.


#5

Unfortunately, we currently don’t have such type of repository publicly
available but we try to track all requests even if we don’t answer to every
single one. Also, we usually post the list of major issues resolved in the
beta’s Release Notes.
[…]

ok. I will trace it from my own.


Butter