Toad World® Forums

Creating a new table


#1

OK, this is brutally slow.

First, I click on the + sign on the display of an existing table and it takes 10 seconds or so to bring up the new Table dialog.

Then, after typing a name for a column, I press tab. It’s got to be at least a second between tabs. Not sure what you guys are trying to do here, but something is out of whack.

Jet


#2

This whole interface is slow. If you add a trigger and then click on the icon “Apply changes to DB”. It takes approx 15 seconds, if you generate the sql and then run it, it takes sub second.


#3

Hello

I do not experience that…even using VPN connection…
I tried with DB explorer and DB navigator

Are you getting some messages in the output window?

Filipe


#4

Joe,

I tried this against a 9.2.0.8 and 10.2.0.4 database, but could not reproduce it.
Maybe a temporary contention on something like dba_tables?


#5

So, if you bring up an existing table.

Click on the blue + sign at the top of the dialog

How long does it take to come back? For me 10 seconds.

Then, once I get box where I can type new column names, tabbing from name to type to length is also extremely slow.

I’m using 6.2.0.1317

Don’t know why mine would be slow.

I do know, starting the create table dialog has always been slow.

Jet


#6

I think I figured out the tabbing problem is because it’s not going to the next field, but it’s going to other tabs and other fields in the dialog. In other words, your tab order is out of whack.

jet


#7

Yes they’re a bit messed up but it has been fixed in our current internal build. Please check the next beta when it’s available.

Cheers,
Gwen