Toad World® Forums

Cross Connection Error - Error trying to reestablish lost connection


I was successfully using the cross connection query below until about a month ago when I started getting the error "Error trying to reestablish lost connection - Reading from the stream has failed". When I try to run the query it runs for up to 10 seconds before giving the error.

Since then the query has not worked, I have tried researching the error but have not found an answer. I have uninstalled/reinstalled Toad and tried remaking my connections. Thank you in advance for any help you can provide. I liked using this feature but have now gone back to running this query and others in each connection and then combining them after export, which is tedious.


64 bit. TNS connections. Toad Data Point 4.3



Both connections look like below: (Posting separately because of forum photo limits)

I have never seen this error message, and looks like there are no Knowledge Base articles related to this issue. My first thought here is to ask if something has changed in your Oracle world (config changes, database upgrade, network changes, etc.).

I would definitely take this up with our Support staff, who are better equipped to help you troubleshoot, especially if the query was running successfully before.

Hi Claire,
Please try and check below info first:

  1. Can you connect to the "Local Storage" of Toad Data Point?
  2. You can retrieve data from above data source separately, means those data sources works fine in non-cross-connection, right?

If above checking is ok, please send the support bundle to us:

  1. Run the cross query and get the fail result again.
  2. Generate support bundle - "Help"->"Support Bundle"
  3. You can get the support bundle zip file when you right click the tab of support bundle in main window,

Hi Gary,

Thanks for responding. I did try to work with the IT resources at my company to see if anything had changed. They asked me to try writing my query with the connection name at the end. When I tried it I got the same error.


The only real change during that time was moving from Windows 7 to 10. I’m not sure if that’s significant, but I also have a remote desktop with Toad that did not get the Windows update and the cross connection queries work just fine there including the query I originally posted .

Hi Vincent,

Yes, I am able to connect to the Local Storage and the data sources from my original query work just fine and produce the expected results when I break the query up and run them individually.

Thank you I will send you the support bundle today per your instructions.


How long should it take to generate the support bundle? I followed your instructions to generate it but no tab came up like in your screenshot. I waited an hour. Is that normal?

It is not normal, the tab should be show up quickly like below, if you cannot see the tab, there must be something wrong.
I suggest you close the TDP to open it, then try again.

If you still have the problem, please try zip the log files below manually to us:

  1. C:\Users\YOUR_USER_ID\AppData\Local\Quest Software\Toad Data Point Hub Data\logs
    All files
  2. C:\Users\YOUR_USER_ID\AppData\Local\Quest Software\Toad Data Point Hub Data\data
    xxxxxxxx.err , here xxxxxx is your machine name
  3. C:\Users\YOUR_USER_ID\AppData\Roaming\Quest Software\Toad Data Point 4.3

We would still like to help you with this issue. if you like you can open a support case and they have assist

Was there a resolution to this? I am having the same issue.