Toad World® Forums

CTRL+SHIFT+ALT Selection Ranges ignored by Replace feature


#1

Today someone e-mailed me a list of fields to be included in a query:

“Prod Code”

“Vendor Code”

“Inventory UOM”

“Effective Date”

“Vendor List Price”

“Vendor Multiplier”

“Exchange Rate”

“Freight”

“Duty & Brokerage”

“Markup Factor OEM”

“Markup Factor POS”

“OEM Selling Price”

“POS Selling Price”

Because I’m picky, I want to replace the double-quotes with Square Brackets, so
using CTRL+ALT+SHIFT I selected the range like this (see Screen capture):

Press CTRL+F to open the find/replace dialog, and told it to replace " with ]

Here’s the result:

"Prod Code]

]Vendor Code]

]Inventory UOM]

]Effective Date]

]Vendor List Price]

]Vendor Multiplier]

]Exchange Rate]

]Freight]

]Duty & Brokerage]

]Markup Factor OEM]

]Markup Factor POS]

]OEM Selling Price]

]POS Selling Price]

Not what I had in mind.

If I do the exact same operation in SSMS, it works as expected:

In this screen capture, you can see that it completed the “right half” selection
correctly, and now I’m preparing to do the “Left half”. On clicking replace all,
it completed and I ended up with what I wanted:

[Prod Code]

[Vendor Code]

[Inventory UOM]

[Effective Date]

[Vendor List Price]

[Vendor Multiplier]

[Exchange Rate]

[Freight]

[Duty & Brokerage]

[Markup Factor OEM]

[Markup Factor POS]

[OEM Selling Price]

[POS Selling Price]

Issue #1 is that Toad isn’t respecting the CTRL+ALT+SHIFT selection range in the
Replace dialog.

Issue #2 is that once I realized the error I pressed CTRL+Z to undo and it DID
NOT WORK – the Undo option was also greyed out from the menu.

Why did I lose the ability to Undo? That seems pretty serious to me.

Darren

image004.png