Toad World® Forums

Database, Date Collected, Time collected are grayed out on Optimize Indexes for Spotlight Statistics Repository


#1

Hello,

I am trying to optimize indexes on an instance. All of the options for the selected server are grayed out. This is version 9.5. I am trying to pull from the SpotlightStatisticsRepository. I am an admin on both servers. The instance is actually a virtual instance for a cluster. However, I change to other servers that are not and the say results occur. An error shows that says “There isn’t date collected in current select criteria.” All the other options are grayed out though. Any thoughts?


#2

Hi,

Above the “SQL filter criteria” box, there are 2 dropdowns for you to specify where your Spotlight Statistics Repository resides:

  • “Select the database of the source”

  • “Database”

Firstly, select a connection in the “Select the database of the source” dropdown. Once you have connected to the server, you should see the second “Database” dropdown enabled. Then in this “Database” dropdown, you can select the database where the Spotlight Statistics Repository is installed. Only when you have a valid connection and a database with a Spotlight Statistics Repository found in it will the controls inside the “SQL filter criteria” be enabled. If you have selected a database without a Spotlight Statistics Repository in it, then you should see a red exclamation mark icon telling you the problem.

Please double check the location of your Spotlight Statistics Repository and try the steps above. If the problem still persists, please contact our Support team so they can give this problem a closer look.

Thanks,

Alex


#3

Thank you. I did everything stated. The database was grayed out too. I contacted support and they thing it is internal error with the program. Thank you for your support!

  • *Nicole Barnard

Sr. Database Administrator

2401 S. 31st Street, Temple, Texas 76508

Ext: 24-5405|Office: 254-724-5405|MS-26-A304 |

SNOW Group: ** App-Clinical-Web Services-T3**

Emergency Page/E-mail: SWDBA_Alert@sw.org

NOTE: When entering a ticket for the DBAs, please include the name of the Project and/or Server(s) name in the short description field. Also, include a due date to help us keep on track with getting high priority tasks completed.

Thank-you

If you are pleased with the service you received please consider recognizing me on INNERGIZE! J

https://innergize.sw.org

From: Alex Luk [mailto:bounce-AlexLuk@toadworld.com]

Sent: Tuesday, October 06, 2015 10:09 PM

To: sqloptss@toadworld.com

Subject: RE: [SQL Optimizer for SQL Server - Discussion Forum] Database, Date Collected, Time collected are grayed out on Optimize Indexes for Spotlight Statistics Repository

RE: Database, Date Collected, Time collected are grayed out on Optimize Indexes for Spotlight Statistics Repository

Reply by Alex Luk

Hi,

Above the “SQL filter criteria” box, there are 2 dropdowns for you to specify where your Spotlight Statistics Repository resides:

  • “Select the database of the source”

  • “Database”

Firstly, select a connection in the “Select the database of the source” dropdown. Once you have connected to the server, you should see the second “Database” dropdown enabled. Then in this “Database” dropdown, you can select the database where the Spotlight Statistics Repository is installed. Only when you have a valid connection and a database with a Spotlight Statistics Repository found in it will the controls inside the “SQL filter criteria” be enabled. If you have selected a database without a Spotlight Statistics Repository in it, then you should see a red exclamation mark icon telling you the problem.

Please double check the location of your Spotlight Statistics Repository and try the steps above. If the problem still persists, please contact our Support team so they can give this problem a closer look.

Thanks,

Alex

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from SQL Optimizer for SQL Server - General
notifications altogether.

SQL Optimizer for SQL Server - Discussion Forum

Flag
this post as spam/abuse.

This message contains confidential information and is intended only for the named individual. If you are not the named individual you are strictly prohibited from disseminating, distributing, or copying this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. The sender expressly reserves all privileges and confidentiality which might otherwise be waived as a result of an erroneous or misdirected transmission. E-mail transmission cannot be guaranteed to be secure or error-free as information could be intercepted, corrupted, lost, destroyed, arrive late or incomplete, or contain viruses. The sender therefore does not accept liability for any errors or omissions in the contents of this message, which arise as a result of e-mail transmission. If verification is required please request a hard-copy version. No employee or agent is authorized to conclude any binding agreement on behalf of Scott & White Healthcare or any affiliated entity with another party by email without express written confirmation by the CEO or the Vice President of Supply Chain Services. Scott & White Healthcare www.sw.org