Toad World® Forums

Database on editor resets back to first database in the list


#1

I’ve noticed recently (and this occured in 5.0 as well), that sometimes the
database I’m using for the editor or the database I’m using in the
object explorer will rest itself from the database I’m using (and the one I
have defined on the connection) and instead reset itself to the first database
in the list from the dropdown. Does anyone else have this issue?

Thanks,


Charles Haines
Senior Software Developer
P: (410) 535-5590 x1196

Recorded Books, LLC
http://www.recordedbooks.com


#2

Yes, I believe the focus on the database and the focus on the server is at
issue. Please go into more detail so I can validate that we are on the same
page….

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678.414.0090 my cell Primary
image001.gif


#3

Yes, I believe the focus on the database and the focus on the server is at
issue. Please go into more detail so I can validate that we are on the same
page….

Hank Freeman

Senior Systems, Database/Data Warehouse Architect

hfreeman@msn.com

678.414.0090 my cell Primary
image002.jpeg


#4

I don’t know if this is a related issue…

When I close a tab, the focus tends to go back to the Database selection
dropdown rather than a different tab. What ends up happening is that I
think the focus is on the tab now showing. So, I use the mouse scroll
wheel on the editor, which, of course, no-can-do because the tab doesn’t
have the focus. Instead, I inadvertently (and frustratingly so) end up
changing databases.

My thought: The database dropdown should never get the focus upon
closing or moving of a tab or other controls/windows.

  • Matt

#5

Hi Matt,

I understand what Charles is talking about in his first email. We already have a
CR to address this issue.

But I need some details on your last email to be sure that you are talking about
the same or not. Can you please add some specific details with screens?

Thanks in advance.

regards,

Alexander Maximov