Toad World® Forums

DataDiff Vier error


#1

Hi,
I made a compare of current result with old one. Old result was gained yesterday, meanwhile I get message ORA-03114: not connected to ORACLE. I reconnected to server, but did not refresh result.

Compare tools showed me for a moment 2 data sets then changed - you may see result above.

System.NullReferenceException
Object reference not set to an instance of an object.
Stack Trace:
at Quest.Toad.Grid.ToadGridControl.gridView_CustomColumnDisplayText(Object sender, CustomColumnDisplayTextEventArgs e)
at DevExpress.XtraGrid.Views.Base.ColumnView.RaiseCustomColumnDisplayText(CustomColumnDisplayTextEventArgs e)
at DevExpress.XtraGrid.Views.Base.ColumnView.RaiseCustomColumnDisplayText(Int32 rowHandle, GridColumn column, Object _value, String displayText)
at DevExpress.XtraGrid.Views.Grid.Drawing.GridPainter.DrawRegularRowCell(GridViewDrawArgs e, GridCellInfo ci)
at DevExpress.XtraGrid.Views.Grid.Drawing.GridPainter.DrawRegularRow(GridViewDrawArgs e, GridDataRowInfo ri)
at DevExpress.XtraGrid.Views.Grid.Drawing.GridPainter.DrawRow(GridViewDrawArgs e, GridRowInfo ri)
at DevExpress.XtraGrid.Views.Grid.Drawing.GridPainter.DrawRows(GridViewDrawArgs e)
at DevExpress.XtraGrid.Views.Grid.Drawing.GridPainter.DrawContents(GridViewDrawArgs e)
at DevExpress.XtraGrid.Views.Grid.Drawing.GridPainter.Draw(ViewDrawArgs ee)
at DevExpress.XtraGrid.Views.Base.BaseView.Draw(GraphicsCache e)
at DevExpress.XtraGrid.GridControl.OnPaint(PaintEventArgs e)
at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer)
at System.Windows.Forms.Control.WmPaint(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at DevExpress.XtraEditors.Container.EditorContainer.WndProc(Message& m)
at DevExpress.XtraGrid.GridControl.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


#2

I’ve seen this error, too, using Teradata .Net. Again, lazy reporting on my part.


#3

Thank you for reporting the error.
I created CR 106811 to track it.