Toad World® Forums

DBA Views


#1

I know we had this discussion before, I understand that in the new db explorer dba views is not available, but I went out to old db explorer and found a package body owned by a different user, then double clicked the package body, it came up in the editor with only the specs available and no tab (not even greyed out) for the package body. I verified I do have the endable dba_views selected. I tried it in 5.5 and I am able to see the package body… I understand we can not search in the new db explorer in the 6.0 version, but when we find what we need in the old explorer we need to have the same permissions we did in 5.5.


#2

Hi Dale,

We could not reproduce your issue. When the spec of the package is displayed, can you open the body manuallly by clicking on the button shown in the attached snap shot?

Gwen
openpackage.gif


#3

I thought I had replied to this, guess I didn’t. This one is going to hurt. Most of our stuff we support is not owned by us. But we are expected to research and resolve any issues. With that little bit of whine out of the way, I clicked the icon in your screen shot and got the attached message. I checked the permissions and we have only execute granted to us. I checked 5.5 and we can see both tabs. Any assistance would be appreciated.
packagebody.gif


#4

Hi Dale,

This problem must be fixed ASAP. Code Editor should be able to use DBA views to open objects.

Regards,
Roman


#5

One question: which version of Oracle DB are you using?

Thanks,
Roman


#6

You gave us a tricky issue Dale. I haven’t been able to reproduce it yet. This is what I have done so far:

  • I granted execute on a package to a non-DBA user
  • loged in as that user and view the package
  • The package spec was displayed in both DB nav tree and DB explorer tree
  • Double click to open
  • Only the spec is displayed but this is what it supposed to do. (5.5 works the same as well)

As you have stated above, you double click the body to open the package but as far as I know, if only Excute is granted on the package, you cannot view the body and it wouldn’t show up in the tree. (even if you use DBA view). So I suspect that you have some other permission that let you view the body. I tried this way as well. And the result was both spec and body are visible in the trees. When you double click the body to open the package, both tabs are displayed (this is also consistent between 5.5 and 6).

I also asked the DBA guy but he hasn’t figured out yet how to reproduce this. It would help if you could provide information on what kind of permissions or roles are granted to your user as well as the packages.

Thanks
Gwen


#7

I disagree (You Wrote: "if only Excute is granted on the package, you cannot view the body and it wouldn’t show up in the tree. (even if you use DBA view). "),

if you have access to dba_source (sqlplus):
1* select * from dba_source where name = ‘LCA_PRICE_QUOTE’

OWNER NAME TYPE LINE


TEXT

**** LCA_PRICE_QUOTE PACKAGE 1
PACKAGE lca_price_quote AS

You can see the source regardless of permissions on the package itself…

Attached is a word doc with printscreens (please forgive me I am not a paint app pro).

I don’t know what else to tell you as far as permissions are concerned
NAV 6.doc (971 KB)


#8

The reason we could not reproduce your issue was because we didn’t know what kind of priviledges your user had. Different priviledges may give different results. Anyway, we managed to nail down those priviledges yesterday and have fixed the problem. A build will be available to be verified soon.

Cheers
Gwen


#9

Hi Dale,

Could you please advise if you are happy with the fix for the DBA view issues.
Build 1051 is now available for you:
http://sqlnavigator.inside.quest.com/shares/sqlnavigator/sbin/beta/1051/sqlnav_6.0.0.1051-KX_beta.zip

Thanks and regards,
Bruce


#10

I ran the install, the help about still shows 1049. I tested the fix, no changes (still not working), so I ran the install agian and it says installed… I did not run the Quest Installer, didn’t know if I should. Please let me know…


#11

Hi Dale,

The build number should be 1051.

Could you please uninstall SQL Navigator by running Quest Installer fromStart->All Programs->Quest Software->Quest Installer->QuestInstaller. Then run the build 1051 install again.

Thanks,
Bruce


#12

Shows 1051 and I am now able to see package bodies , thanks bunches…


#13

Thanks Dale for the update. Great to hear that you can use see the package bodies now :-).

Thanks,
Bruce