Toad World® Forums

Debugging Issues


#1

Hi Guys,

Tried using the debugger today.

First issue, no tool tips for the buttons.

Second, when i got done, it made the package read only and I can’t type anything.

Third, the watch tells me that the variable is “<inactive”>, but I can see the value in the locals tab.

Next, shouldn’t I be able to do something like put a watch on " LENGTH(vbigstring)" or at least get an evaluation of such?

It would be nice to be able to double-click on a variable and see the whole value in a pop up. It’s needed for long varchars.

How do you remove Watches? I tried right-click and delete. But no luck ?:expressionless:

all for now.


#2

the second one: it is a bug and it will be fixed
the third one: I couldn’t reproduce this one. the watch is displayed inactive when its out of scope
To delete a watch, select the watch and choose Delete under the Watch/Break menu or press Ctrl+ Delete .
Gwen

Message was edited by: Gwen


#3

Hi Jet,

Currently debugger only is able to evaluate expressions that include variables, literals, arithmetic and logical operators, concatenation, indexes and comparisons. Built-in or user-defined functions are not supported yet. 5.5 didn’t do this either, so this enhancement is on our list for future versions.

Watches are removed by Ctrl+Del or via the Watch/Break menu. The watch has to be selected in the list.

Regards,
Roman