Toad World® Forums

Deleting and recreating Test causes Violation of unique index "UN_QU_HRN_NA


#1

I just started to learn about Quest Code Tester for Oracle.

I created a test on a function GET_LAST_DAY. After some tests I deleted this test and tried now to make a new test on the same function. Trying this I get the following error:

Violation of unique index “UN_QU_HRN_NAME”

We tried to insert or update a row of data, and ran into the following problem: at least one of the values are already in the database and you are not allowed to have duplicates.

This error occurred on the table named QU_HARNESS, which is owned by TOAD_TESTER. The name of this unique constraint is UN_QU_HRN_NAME. In some cases, we may be able to also display the columns and values that triggered the conflict. If available, they follow below.

HARNESS_OWNER = IGVV_TEST
NAME = Q##GET_LAST_DAY

I also have problems in importing an export. After the import I can just see the suite but none of my testcases…


#2

Are you using a commercial or trial version? If so, you should submit a bug report to Quest Support, along with a support bundle. That will be the best way to deal with your issues. That would answer questions like:

  • What version of Code Tester?
  • What version of Oracle?
  • Did you install into a central schema and create public synonyms?
  • From which schema did you create the tests? Were you logging into different schemas?

Feel free to answer these here, but again, best is to use Quest Support.

SF


#3

I am using a commercial version. I suppose I know why I have this problems… I read somewhere: Code Tester is currently an instance-specific tool. This might be the problem in my environment… I think I will check this first. It seems we had an idea to work with Quest Code Tester which is not possible (Schema IGVV for development, Schema IGVV_TEST for Quest Code Tester,…).

Thank’s anyway!


#4

Different SCHEMAS are fine; different INSTANCES are not. In other words, you cannot install CT in DB TEST2 and then connect to a schema in DB TEST1 and use the TEST2 repository. That should not be the problem.

What version of Code Tester are you running?


#5

We have version 1.5.2.105


#6

OK, you are WAY BEHIND. Current production version is 1.8.1. You should definitely and completely stop working with 1.5.1.

Upgrade to 1.8.1. If you have not already created any tests you want to save, just start fresh.

SF