Toad World® Forums

Deleting rows from grid, using ctrl+del


#1

Hi!

Some things i 've observed, so when i have grid in edit mode, deleting rows using popup menu works fine, but using shortcut not always.

Afther tests , it looks like , that it works ok when i run query and then select any cell from row using arrows (without mouse clicking), then ctrl+del work great. But if I select row# cell (because selecting other cells edits them) using mouse, it doesn’t work. Afther that , when I edit single cell and then using arrows move to another cell, it’s works again.

Check this
Regards Piter.

Ps. Why “select * from tab” can be edited, but “select * form tab a” not ?


#2

Hi Piter,

Very nice catch here :-). There are some issues with the shortcut keys in the data grid. We will raise a request for you and will get this fix for you in the next 5.5 beta build.

“select * from tab” and “select * from tab a” gave me the same result, both results I could not edit…whether I turn on or off the Updatable button…I will need to check with the Team tomorrow and get back to you on this later.

Thanks and regards,
Bruce


#3

SOORRY BRUCE ABOUT MY NAMING METHODS.
I had mistake with naming, i called “tab” thinking about any default tab, but TAB is a oracle dictionary!
I should write select * from [any_table].


#4

Hi Piter,

Thanks for your note. Feel much better now. Yeh, aware that Tab is the Oracle Table . When trying your query earlier, got very concerned that SQL Nav allows you to edit the data of TAB table…

Will ask Roman to get back tomorrow on why the result set return as read only when running ‘select * from anytable a’. I just tried selecting with colum names then it can be editable…

Regards,
Bruce


#5

Thanks Bruce!

Ps. Can’t you sleep?? :wink: I supose it’s 5 am in Australia…


#6

It was 10pm last night Piter in Oz. Doing a late shift for you.


#7

of course its +9 hours from my, not -9 :wink:


#8

This issue has been around for a while (you should have picked it up in the last beta program Piter ). The right click and shortcut options are severely hampered when you have the Row# selected.
But, it isn’t right, and we will fix it… I have raised a CR for it now!!

Plus I found another issue; related to deleting a row that has other dependencies (no error is recieved, but nothing happens), which I have also logged a CR for. So thanks Piter!!

Jaime