Toad World® Forums

dot lookup disable....for shorth time


If you make a new SQL tab and disable there the dot lookup after you execute the SQL the dot lookup is again ON



That is really weird. We will fix it. Thanks for your feedback, Filipe.



Maybe I see it wrong but it appears that with this new build the dot lookup is always on when the Auto Completion/ Dot Lookup button in code editor is off
(maybe the help/manual is wrong and the button only changes the auto-code?)

also where is the Auto-Reparse button in code editor?



Hi Filipe,

In previous version of Nav, we merged Code Completion/Dot-Lookup into one because they’re quite similar. However, we received feedbacks from the customer that they prefer to have them separate. Specifically, they want dot-lookup to be ON and code completion (pick list for keywords, etc.) to be off because it’s too troublesome. As a result, we have 2 preferences in the Preferences window. This button only turns off the Code Completion not the Dot-lookup.

Auto Reparse can be found in the right-click menu.




I think the “online help” and “user guide supplement” should change to be “in one mind” with that
For instance the entries in “Code Editor toolbar commands” (Auto Reparse should disappear and “Auto Code Completion/ Dot Lookup” should only be “Auto Code Completion”

I hope you do not think me very annoying :wink:




Hi Filipe,

I have updated the ‘Online help’ to reflect the changes. We may not have time for the ‘User supplement’ though due to limited resource.