Toad World® Forums

dot notation weirdness


#1

Ok, I don’t know if this is a feature, but if

You have the following:

Select * from table t;

And then you delete the * and start to type, right next to the word from “t.” and think pick a column name from the list that pops up, Nav will erase the word from.


#2

Hi Joe,

I have tried to reproduce your problem. It happens only if I delete ‘*’ AND the following space. Is it what you are experiencing?

Regards,
Roman


#3

nope.

If I type

select * from table ta

then put my cursor right before the from
then type “ta.”
nav presents me with a list and when I select an option, it overwrites the “from” with the column I picked.

It’s been doing this for awhile, I just finally figured out how to make it happen.


#4

Now I don’t understand. You type select * from…, then put the caret at the beginning of ‘from’ (leaving ‘*’) and start typing. Right?

Code Completion replaces the word following the dot, it’s the correct behavior. If you just delete ‘*’ and start typing (leaving a space before ‘from’), what happens then?

Roman


#5

Hi Roman,

If I do what you ask, it works fine.

As I said in my original post, “I don’t know if this is a feature” Sounds like it is. I’m not sure I like it, but I can see where it would be useful sometimes.

Thanks,

Jet