Toad World® Forums

Editor lookup - sugestion


#1

Hi!

One small thing i’ve observed. When you hit use ctrl+space after dot, to lookup for procedures in package, arrows, tab and enter works fine. But when you type some letters to reduce lookup list , arrows, tab and enter not always work as expcted. Sometimes lookup list disapears, tab, enter do complete typed word…
Sometimes it works fine but usually not.

Check this!

Regards Piter

broken.jpeg

good.jpeg


#2

Hi Piter,

I’m unable to replicate this issue… But I will keep paying attention to it.
I’ll let you know what I find!!

Jaime

PS: I just now saw the picture of you and Andrew drinking Polish beer together…
Wish I could have been there to join you two!!


#3

It would be wonderful to drink beer with all of your team!! Maybe some day …
Andrew was first one, we had only one evening for discussion…but we can use this community to continue!!

Now About sqlnav.
Try , like in attachements:
dbms_output. > ctrl+space > type “put”


#4

Now Piter,
I always follow your examples!! They are always so well explained and helpful.
When I do follow your example, I do not get the blank ‘Lookup’ window (see my attachment).

I have tried about 50 times, and none of them have failed
Could it be environmental?? What client and database versions are you using?
I’m using 10g2 client and 10g2 database.

Jaime
put.jpeg


#5

Hi Jaime!
My database is 10gr2 and client is in the same version.
So this issue occurs when i have use DBA viewvs enabled, without this option i didn’t noticed that situation.

Enable dba views usage and then test.
Try dbms_lob.<ctrl +space> type “com” and hit three times down arrow… after that i see > attachement

This happends not every time, once on 3 tests

Regards Piter
untitled-2.jpeg


#6

Hello again,

Still no luck Piter. I get no blank lookup window.
I’ve tied with and without DBA views…
As soon as I enter the . (dot) the lookup window appears, so I don’t need to use +

BUT I have tried it also, setting up the scenario where I do have to use the
+ to launch the lookup window.
Still no blank lookup screen noticed.

Jaime
com.jpeg


#7

Lookup window is showed with items, but when i use arrows, items disappears…


#8

Yep… understood Piter,
But is not the case for me, and Andrew has been trying replicate, and has had no problems either.
We will keep an eye on this issue!!

Jaime


#9

Ok maybe it’s my Win, i will check on other machines. However this is not big problem, we can leave it , you have more important things to do…

Regards Piter


#10

Last post in this thread… >attachement
clip0004.zip (60.6 KB)


#11

New last post on this thread
See attached.

Jaime
dbms.zip (339 KB)