Toad World® Forums

Editor too slow


#1

Hi again

I run a script with 146345 lines.
Select all the script and replace it using paste with a script with 37618 lines.
It took more than 15 seconds …

exchanging this last one the another with 13 lines took more than 10 seconds…

Filipe
PS: I think also that running scripts is slower but I could be wrong…


#2

Hi Filipe,

There’s probably not much we can do to improve paste performance. The editor does a lot of work in the background (e.g. parse text to ensure syntax highlighting), and optimising it is not an easy task. My only advice is not to use such large scripts. For instance, you can split your script into several files and use 6’s support for nested scripts a la SQL*Plus.

Speaking of run performance, do you mean it’s slower in this build compared to the previous?

Regards,
Roman


#3

about performance: yes, comparing with the previous beta build with a similar length script.

I noticed that if a script has more that 10000 lines code collapsing is disabled to improve performance so I do not understand the paste/replace time for the first scenery.
At least for the second scenery I mention the volume of lines is small.

Regards
Filipe


#4

Hi Filipe,

I tried pasting a large script with the same amount of lines as yours but didn’t see any difference between the two builds. They only took around 4,5 seconds for me.

Gwen


#5

I don’t know if this is related or not, but I copy text (sql) that I have written and tested on the test system, open a production window hit ctl-v then F-9 in all the navigators I have used 4.x-6.x I have never seen this window before. Now in this version 6.2.0.1332 I get this all the time. If I pause for a second before hitting F9 it is fine, but I never used to have to.
notexttorun.gif


#6

Hi Dale,

This is fixed in our internal build. Please check it again in the next beta release. Thanks

Gwen