Toad World® Forums

Enable Using DBA views disabled?


#1

Hi

I found out this (I do not know if it was already reported)

if I start a session and the I tried to start another with the same DB and user the ‘Enable Using DBA views’ option is disabled…That happens even I connect with a DBA user
Workaround: edit the username and them put it back :slight_smile:

Thanks

Filipe


#2

Hi,

I was not able to reproduce on my desktop. It works fine for me. I am using DBA connections on both.

Thanks
Vas Lakshman


#3

Hi Filipe,

This is to make sure that if you have two or more connection to a DB using the same user, the permissions are all the same. I think it’s a feature not a bug. It’s also in 5.5.

Gwen


#4

Hi Gwen

That doesn’t avoid having several connections to the same user …only enabling DBA views in the other connection
It’s really a minor thing …

Filipe


#5

Hi

A minor issue for 6.3 :slight_smile:

Ok.
0. having a user connect in the SQLNav with/or without DBA Views enabled

  1. If you make a new session (in the same SQLNav) with that user you cannont change the “DBA Views enabled” option (it uses the previous one) = that’s a feature
  2. If I open the new session dialog it will present in the username my previous username used.
    If I delete only the last char I still cannot change the “DBA Views enabled” option.
    workaround: If I delete another char and then write that one and the previous I can then change.

Regards
Filipe


#6

The previous is a collection of old posts and maybe at that time I didn’t get all the picture, but even today I ready do not understand why not make it possible to have a connection with DBA views on and another with off is not possible without the working around described in the previous post.