Toad World® Forums

Error creating test for function where name has 30 char


#1

I have a package that contains a function whose name is 30 characters long. When I tried to create a test case for it, I received an error:

UNANTICIPATED-ERROR
Unexpected failure when initializing test definition from program definition.

ORACLE_ERROR = ORA-06502: PL/SQL: numeric or value error: character string buffer too small

When I shortened the function name to 22 characters, the test case generated and ran fine. I did not push the limits to see exactly where it breaks, but when I changed it back to 30 characters, it did break again.

I’m OK with the shorter function name, but figured the limits should sync’d up with Oracle if they are not already.

Thanks,
Mitch


#2

Thanks, Mitch. This is a bug, and we have fixed it in 1.8.3.


#3

Gotcha. Thanks for the quick reply.
Just out of curiosity, do you have a target release date for 1.8.3?

Thanks,
Mitch


#4

We plan to freeze code next week, then several weeks of testing, so I expect a date towards the end of March.