Toad World® Forums

Error Message when Opening Automation Scripts


#1

Hi there,

I’m having an issue any time I try to Open any Automation script using all methods (File Open, Project Manager, etc.) I get the below message every time and the only way for me to run 6-7 Export Templates is to do it manually :frowning:

Any ideas? I’ve uninstalled and re-installed with no luck.

System.IO.FileLoadException
Could not load file or assembly ‘DevExpress.XtraNavBar.v8.2, Version=8.2.4.0, Culture=neutral, PublicKeyToken=9b171c9fd64da1d1’ or one of its dependencies. Element not found. (Exception from HRESULT: 0x80070490)
Stack Trace:
at Quest.Toad.Workflow.UI.Toolbox.InitializeComponent()
at Quest.Toad.Workflow.UI.Toolbox…ctor()
at Quest.Toad.Automation.AutomationForm.AutomationForm_Load(Object sender, EventArgs e)
at System.EventHandler.Invoke(Object sender, EventArgs e)
at System.Windows.Forms.UserControl.OnLoad(EventArgs e)
at System.Windows.Forms.UserControl.OnCreateControl()
at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
at System.Windows.Forms.Control.CreateControl()
at System.Windows.Forms.Control.WmShowWindow(Message& m)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.UserControl.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


#2

One of the files being used has a dependency on a third party dll in a prior relase.

If you would send me the automation script and all linked files I can determine which file has the bug and give you a work around.

Debbie
dpeabody@quest.com


#3

Hi Debbie,

Here is the Automation Script and all files used.

One note I get this error message on ANY Automation Script I run and I have many of them.
Monthly_Automation_Script.tas (6.46 KB)


#4

Hi Debbie,

Here is the Automation Script and all files used.

One note I get this error message on ANY Automation Script I run and I have many of them.
weekly_dealer_counts_use.txp (3.62 KB)


#5

Hi Debbie,

Here is the Automation Script and all files used.

One note I get this error message on ANY Automation Script I run and I have many of them.
weekly_dealer_counts_tytd.txp (2.68 KB)


#6

Hi Debbie,

Here is the Automation Script and all files used.

One note I get this error message on ANY Automation Script I run and I have many of them.
weekly_dealer_counts_tot.txp (6.46 KB)


#7

Hi Debbie,

Here is the Automation Script and all files used.

One note I get this error message on ANY Automation Script I run and I have many of them.
weekly_dealer_counts.txp (3.97 KB)


#8

Hi Debbie,

Here is the Automation Script and all files used.

One note I get this error message on ANY Automation Script I run and I have many of them.
weekly_dealer_counts_ytd.txp (2.91 KB)


#9

Hi Debbie,

Here is the Automation Script and all files used.

One note I get this error message on ANY Automation Script I run and I have many of them.
weekly_dealer_counts_uytd.txp (2.72 KB)


#10

You are correct. This error is not coming from any of your scripts. This file is needed to open the Automation Toolbox.

What version are you using of TDA? The file it can not load was from TDA 2.1. I would suggest you upgrade to TDA 2.5. Or, do a repair or uninstall/reinstall of TDA 2.1. This should set the files right again.

let me know if this resolves or not.

Debbie


#11

I tried the Uninstall/Reinstall with no luck. I’ll try Repair next.

I’m working on renewing my Maintenance License so if this doesn’t work I will work on upgrading. Thank You.


#12

It is also possible that there is something messed up in your GAC.
Try going to the install dir and doing these two steps.

  1. Run ngenUninstall.bat.
  2. Run NGenWrapper.exe

This takes some time but resets the GAC for the files in TDA.

You send me NGen.txt when done and I confirm the reset worked ok.


#13

Hi Debbie,

I did the below and here is the output file.
NGen.txt (5.15 KB)


#14

Mnnnn…I forgot. TDA 2.1 has an error in NGen in this version.

Did the uninstall/reinstall work?


#15

No I’ve tried 3-4 times. I’m just going to get my license renewed so I can upgrade.

Thanks for helping.


#16

Sounds good.